Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354560 - virt-viewer crashes gnome-shell
Summary: virt-viewer crashes gnome-shell
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 14:56 UTC by Vladimir Benes
Modified: 2016-11-04 01:44 UTC (History)
4 users (show)

Fixed In Version: gnome-shell-3.14.4-51.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:44:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
gnome-shlle gdb out (deleted)
2016-07-12 14:31 UTC, Tomas Pelka
no flags Details
gnome-shell gdb out (deleted)
2016-07-12 15:00 UTC, Tomas Pelka
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 674799 None None None 2016-07-12 15:16:15 UTC
Red Hat Product Errata RHBA-2016:2258 normal SHIPPED_LIVE gnome-shell, gnome-shell-extensions, and gtk3 bug fix and enhancement update 2016-11-03 13:32:13 UTC

Description Vladimir Benes 2016-07-11 14:56:31 UTC
Description of problem:
While starting virt-viewer gnome-shell goes down into oops screen. 

Version-Release number of selected component (if applicable):
gnome-shell-3.14.4-50.el7.x86_64
virt-viewer-2.0-10.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.start virt-viewer

Actual results:
GS crash

Expected results:
no crash

Additional info:
no abrt crash, no backtrace in gdb, just SIGABRT caught. Reproduced on two independent boxes

Comment 2 Tomas Pelka 2016-07-11 15:21:06 UTC
Most probably related to https://bugzilla.redhat.com/show_bug.cgi?id=1353613

Comment 3 Tomas Pelka 2016-07-12 14:27:47 UTC
I can trigger that also by libreoffice and cssh

Comment 4 Tomas Pelka 2016-07-12 14:31:04 UTC
Created attachment 1178915 [details]
gnome-shlle gdb out

Program received signal SIGABRT, Aborted.
0x00007f5686ada1d7 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);

Comment 5 Tomas Pelka 2016-07-12 15:00:39 UTC
Created attachment 1178937 [details]
gnome-shell gdb out

Comment 6 Tomas Pelka 2016-07-12 15:16:15 UTC
halfline proposed fix from mentioned bug

Comment 7 Ray Strode [halfline] 2016-07-12 16:58:49 UTC
Just to clarify a bit, the issue is caused by this commit:

Author: Florian Müllner <fmuellner@gnome.org>
Date:   Wed Jul 6 19:56:47 2016 +0200

    app: Add a construct-only app-info property

    This will allow us to create a ShellApp from JS code, for instance
    for .desktop files that aren't known to the AppSystem.

So that means the app-info property will get set unconditionally at instance creation time, even if app-info isn't explicitly set in the property list.

That commit changes _shell_app_new () to set "app-info" explicitly, but _shell_app_new_for_window() doesn't set "app-info" explicitly so the property will get set to NULL at creation time.  

If i'm reading the code right, this will cause two things to happen:

1) app->info getting set to g_object_ref (NULL)
2) shell_app_get_name (app) will get called with app->info NULL and window_backed_app_get_window() will assert because app->running_state fails.  

The patch in bug 674799 should address the second problem.  The first problem probably causes noise in the log so it should probably get fixed too.

Comment 9 Vladimir Benes 2016-07-12 20:57:39 UTC
It works well. virt-viewer works, LO too. No crashes anymore.

Comment 12 errata-xmlrpc 2016-11-04 01:44:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2258.html


Note You need to log in before you can comment on or make changes to this bug.