Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354551 - QCI 1.2: 'Adapter operation failed' when logging in as a different user in Subscription section and selecting 'Add Subscriptions'
Summary: QCI 1.2: 'Adapter operation failed' when logging in as a different user in S...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: James Olin Oden
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 14:33 UTC by Antonin Pagac
Modified: 2016-09-13 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-07-11 14:33:12 UTC
Description of problem:
In Subscription section, when you login as a different user and select step 'Add Subscriptions', there is an error:

'Adapter operation failed'

The error appears because the user is trying to add subscriptions to SMA that doesn't exist in this account.
Moreover, the deployment still works with the old SMA and allows me to add new subscriptions to it and proceed to Installation Review. When I then click Deploy button, it tries to attach subscriptions from portal and UI freezes. From production.log:

'2016-07-11 10:20:12 [app] [E] exception when talking to a remote client: 404 Resource Not Found RestClient::ResourceNotFound: 404 Resource Not Found
 | Body: {"displayMessage":"Consumer with id null could not be found.","requestUuid":"88af24f7-4c5e-451c-98ea-49e08a2945b6"}'

which is expected.

Can we forget all data from the previous user upon re-logging into the portal? Maybe just gray-out the fields that are no longer available, for example adding new subscriptions.
Can we also change the error message to something more descriptive in this case?
Maybe just restricting access to other steps in Subscriptions section upon re-login would work, so user is forced to choose another, existing SMA.

Version-Release number of selected component (if applicable):
20160708.t.0

How reproducible:
Always

Steps to Reproduce:
1. Start a new deployment, go to the Subscriptions section
2. Log-in as a first user
3. Choose a SMA
4. Click on 'Content Provider', click logout
5. Log-in as a second user that is different from the first one
6. Click on 'Add Subscriptions'
7. Error appears.

Actual results:
The deployment tries to add subscriptions to non-existing SMA.

Expected results:
User is forced to choose existing SMA and then allowed to continue.

Additional info:

Comment 1 cchase 2016-07-14 22:01:28 UTC
https://github.com/fusor/fusor/pull/1043

Logout was leaving some data from the old login associated with the deployment in both the UI and in the DB.  Subscription credentials logout now clears the session portal, clears the deployment fields, and deletes fusor subscription records associated with the deployment. This prevents the user from progressing without re-choosing an SMA and also prevents the incorrect association of subscription info due to previous logins.

Comment 2 John Matthews 2016-07-18 21:15:54 UTC
QCI-1.2-RHEL-7-20160718.t.0

Comment 7 James Olin Oden 2016-08-15 14:06:58 UTC
Verified in QCI-1.0-RHEL-7-20160812.t.0

Followed recreation steps above.

Comment 9 errata-xmlrpc 2016-09-13 16:31:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.