Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354529 - compare-bug-version-and-git-branch failing for seemingly no reason
Summary: compare-bug-version-and-git-branch failing for seemingly no reason
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ---
Assignee: Nigel Babu
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 13:46 UTC by Nigel Babu
Modified: 2016-08-08 06:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-08 06:18:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nigel Babu 2016-07-11 13:46:33 UTC
<Saravanakmr> ndevos, nigelb  There is a weird issue - one patch is reporting smoke test error due to another bug 1349657
<glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1349657 low, unspecified, ---, johnzzpcrystal, MODIFIED , process glusterd set TCP_USER_TIMEOUT failed
<Saravanakmr> ndevos, I can see you have changed the status of 1349657 to MODIFIED :)
<Saravanakmr> ndevos, nigelb  http://review.gluster.org/#/c/14830/   - https://build.gluster.org/job/compare-bug-version-and-git-branch/19263/console
<ndevos> Saravanakmr: yeah, the patch for that has been merged?
<Saravanakmr> ndarshan, yes it is merged
<Saravanakmr> ndevos, yes it is merged but seeing issue in another patch
<Saravanakmr> ndarshan, sorry..ignore
<ndevos> Saravanakmr: hmm, right, the other patch is for bug 1351071
<glusterbot> Bug https://bugzilla.redhat.com:443/show_bug.cgi?id=1351071 medium, unspecified, ---, sarumuga, ASSIGNED , [geo-rep] Stopped geo-rep session gets started automatically once all the master nodes are upgraded
<Saravanakmr> ndevos, weird !
<ndevos> Saravanakmr: I have no idea why that could happen :-/
<Saravanakmr> nigelb, can you please have a look?
<Saravanakmr> nigelb, ndevos another patch from Aravinda also fails with same reason http://review.gluster.org/#/c/14627/
<ndevos> Saravanakmr: oh, that actually is the same commit-id, and the commit message is used to parse the BUG:
<skoduri> One of my patches too ran into same issue  - https://build.gluster.org/job/compare-bug-version-and-git-branch/19265/console
<skoduri> nigelb, ndevos , Saravanakmr ^^^
<ndevos> skoduri: is that also doing a "Checking out Revision b2c73cbf423de6201f956f522b7429615c88869d (origin/master)" ?
<skoduri> ndevos, yes
<skoduri> ndevos, and from http://review.gluster.org/#/c/14878/3, looks like that was parent commiID
<ndevos> hmm, maybe nigelb updated the Jenkins job to the new Jenkins Job Builder configuration and some option or something was missed?
<skoduri> okay
<ndevos> obviously there was an update to the new .yml file 2 hours ago, not sure if that goes live automatically
<ndevos> https://github.com/gluster/glusterfs-patch-acceptance-tests/blob/master/jenkins/jobs/compare-bug-version-and-git-branch.yml for the curious, but I have no idea what options are needed or how it releates to other config
<ndevos> nigelb: the compare-bug-version-and-git-branch script expects the to-test change to be checked out, not sure if the JJB config does that?

Comment 1 Nigel Babu 2016-07-11 13:48:01 UTC
It looks like I pushed untested code into Jenkins when attempting to modify the number of days the devrpm jobs are archived. Apologies for this mistake.

I'll accelerate Jenkins making this update so we don't run into this again. This also means that the yml file is wrong and needs more debugging.

Comment 2 Nigel Babu 2016-07-11 13:53:38 UTC
Retriggered all relevant jobs. Anyone who had a failure should have success reported now.

Comment 3 Nigel Babu 2016-07-13 09:25:06 UTC
This was fun to track down: The fix is here - https://github.com/gluster/glusterfs-patch-acceptance-tests/pull/36


Note You need to log in before you can comment on or make changes to this bug.