Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354524 - QCI 1.2: Deployment breaks when choosing different product during the deployment configuration
Summary: QCI 1.2: Deployment breaks when choosing different product during the deploym...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: bmorriso
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 13:39 UTC by Antonin Pagac
Modified: 2016-09-13 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-07-11 13:39:21 UTC
Description of problem:
I started a deployment of RHEV and got to the Storage section. Then I clicked 'edit' near the name of the deployment at the top, and checked OSP and unchecked RHEV. I can now get to step 1B, then the Next button stops working. When I click on '2. RHOSP', which is clickable, I get a blank page.

Version-Release number of selected component (if applicable):
20160708.t.0

How reproducible:
Always

Steps to Reproduce:
1. Start deployment of RHEV, proceed to '2A. Setup Type'
2. Click Next
3. Click 'edit' near the name of your deployment
4. Uncheck RHEV and check RHOS, click Next
5. Next button stops working at 1B
6. When clicking '2. RHOSP' there is a blank page displayed

Actual results:
User is allowed to change products during deployment which breaks the deployment in certain cases.

Expected results:
Unsure; if the user is allowed to change the product during a deployment, he should be allowed to do so without errors

Additional info:
This doesn't happen if you don't input data to RHEV section prior to changing products.

Comment 1 Antonin Pagac 2016-07-11 13:42:50 UTC
Additional info: the failing deployment cannot be deleted using the Delete button in QuickStart Cloud Installer -> Deployments.

Comment 2 cchase 2016-07-12 20:58:21 UTC
https://github.com/fusor/fusor/pull/1030

Fixed OpenStack data creation/validation when turning on OpenStack after the initial create.

Comment 3 John Matthews 2016-07-18 21:15:45 UTC
QCI-1.2-RHEL-7-20160718.t.0

Comment 8 bmorriso 2016-08-11 16:58:56 UTC
Verified with compose QCI-1.0-RHEL-7-20160809.t.1

Following reproduction steps in the description, I was about to progress through a RHEV deployment to '2A. Setup Type', edit the deployment to remove RHEV and replace with OSP, and continue through the deployment wizard without any blank pages or broken Next button behavior.

Comment 10 errata-xmlrpc 2016-09-13 16:31:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.