Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354516 - EC2 provider could not obtain a database connection
Summary: EC2 provider could not obtain a database connection
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.7.0
Assignee: Gregg Tanzillo
QA Contact: Matouš Mojžíš
URL:
Whiteboard: provider:ec2
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 13:22 UTC by Matouš Mojžíš
Modified: 2016-07-19 14:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-18 17:30:27 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
evn error log (deleted)
2016-07-19 14:17 UTC, Matouš Mojžíš
no flags Details

Description Matouš Mojžíš 2016-07-11 13:22:45 UTC
Description of problem:
When I add ec2 provider it spams logs like every five seconds, that it can't obtain database connection.

Version-Release number of selected component (if applicable):
5.5.5.0

How reproducible:
Always

Steps to Reproduce:
1. Add a ec2 provider
2.
3.

Actual results:
[----] E, [2016-07-11T09:21:41.106483 #6382:4d2de68] ERROR -- : MIQ(ManageIQ::Providers::Amazon::CloudManager::EventCatcher::Runner#start_event_monitor) EMS [] as [creds] Event Monitor Thread aborted because [could not obtain a database connection within 5.000 seconds (waited 5.000 seconds)]
[----] E, [2016-07-11T09:21:41.106751 #6382:4d2de68] ERROR -- : [ActiveRecord::ConnectionTimeoutError]: could not obtain a database connection within 5.000 seconds (waited 5.000 seconds)  Method:[rescue in block in start_event_monitor]
[----] E, [2016-07-11T09:21:41.106965 #6382:4d2de68] ERROR -- : /opt/rh/cfme-gemset/gems/activerecord-4.2.6/lib/active_record/connection_adapters/abstract/connection_pool.rb:189:in `block in wait_poll'


Expected results:


Additional info:

Comment 2 Dave Johnson 2016-07-18 17:30:27 UTC
Please retest this Matous, I am able to add a ec2 provider so I believe this can be closed as invalid and I am guessing it was related to the issues displayed in 5.5.5.0 with input fields.  Please reopen if that is not the case.

Comment 3 Matouš Mojžíš 2016-07-19 13:58:30 UTC
This is still happening in 5.5.5.2.

Comment 4 Matouš Mojžíš 2016-07-19 14:16:30 UTC
Whole error in log file attached.

Comment 5 Matouš Mojžíš 2016-07-19 14:17:12 UTC
Created attachment 1181648 [details]
evn error log

Comment 6 Matouš Mojžíš 2016-07-19 14:17:39 UTC
I can add provider, but then eventcatcher doesn't work.


Note You need to log in before you can comment on or make changes to this bug.