Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354502 - QCI 1.2: Cannot cancel deployment from 1A: Deployment Name after filling in name and universal password
Summary: QCI 1.2: Cannot cancel deployment from 1A: Deployment Name after filling in n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: Tasos Papaioannou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 12:40 UTC by Antonin Pagac
Modified: 2016-09-13 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Description Antonin Pagac 2016-07-11 12:40:01 UTC
Description of problem:
I created new deployment, in step 1A I filled in name of a deployment and I also set up a universal password. Then I hit the Cancel button and under the Name field, which is now blank, an error in red is shown:

'This field cannot be blank.'

The deployment is not canceled, I'm still at the step 1A: Deployment Name. The Back button or the Cancel button does not work now. The QCI menu does not work, although I can click on Deployments and New Deployment, nothing is happening.
There is no error in production.log.
Refreshing the page takes me to the Product Selection page and I can create new deployment from there.

Version-Release number of selected component (if applicable):
20160708.t.0

How reproducible:
Always

Steps to Reproduce:
1. Go to Product Selection page, pick a product, click Next
2. In step 1A, fill-in the name of the deployment and the universal password
3. Next should be enabled; click on Cancel
4. 'This field cannot be blank.' appears; deployment is not cancelled

Actual results:
Error appears; after hitting Cancel the deployment is not cancelled; UI seems frozen, buttons don't work, QCI menu doesn'ลง work

Expected results:
I should be able to cancel from any step of the installer

Additional info:
If you don't enter universal password and Next is not enabled, the Cancel button cancels the deployment as expected

Comment 1 Antonin Pagac 2016-07-11 12:45:13 UTC
Additional information: the name of the deployment doesn't seem to matter, what causes this issue are the Universal Password fields. If the fields marked 'Password' and 'Confirm Password' in step 1A are filled-in, and the passwords match, the Cancel button doesn't work.

Comment 2 cchase 2016-07-13 18:00:41 UTC
https://github.com/fusor/fusor/pull/1034

Fixed an exception being thrown when trying to cancel when the Universal Password fields were filled out.

Exception was:

Error while processing route: deployments Attempted to handle event `didSetProperty` on <fusor-ember-cli@model:deployment::ember1307:null> while in state root.deleted.saved. Called with {name: rhev_engine_admin_password, oldValue: undefined, originalValue: undefined, value: asdfasdf}. Error: Attempted to handle event `didSetProperty` on <fusor-ember-cli@model:deployment::ember1307:null> while in state root.deleted.saved. Called with {name: rhev_engine_admin_password, oldValue: undefined, originalValue: undefined, value: asdfasdf}.

Comment 3 John Matthews 2016-07-18 21:15:36 UTC
QCI-1.2-RHEL-7-20160718.t.0

Comment 6 Tasos Papaioannou 2016-07-21 19:52:37 UTC
Verified on fusor-QCI-1.2-RHEL-7-20160718.t.0.

Comment 10 errata-xmlrpc 2016-09-13 16:31:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.