Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354499 - service file is executable
Summary: service file is executable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL: https://bugs.archlinux.org/task/50001
Whiteboard:
Depends On: 1354489
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 12:36 UTC by Niels de Vos
Modified: 2016-08-12 09:47 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1354489
Environment:
Last Closed: 2016-08-12 09:47:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-07-11 12:36:04 UTC
+++ This bug was initially created as a clone of Bug #1354489 +++

+++ This bug was initially created as a clone of Bug #1354476 +++

Description of problem:
journalctl -fa
juil. 09 08:38:37 raptor.seblu.net systemd[1]: Configuration file /usr/lib/systemd/system/glusterd.service is marked executable. Please remove executable permission bits. Proceeding anyway.

Version-Release number of selected component (if applicable):
3.7.11

How reproducible:
100%

Steps to Reproduce:
1. build and install a glusterfs package
2. check permissions of /usr/lib/systemd/system/glusterd.service

Actual results:
/usr/lib/systemd/system/glusterd.service is executable

Expected results:
/usr/lib/systemd/system/glusterd.service should not be executable

Additional info:

--- Additional comment from Vijay Bellur on 2016-07-11 14:27:20 CEST ---

REVIEW: http://review.gluster.org/14892 (build: systemd unit should not be marked executable) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 1 Vijay Bellur 2016-08-09 08:44:05 UTC
REVIEW: http://review.gluster.org/15115 (build: systemd unit should not be marked executable) posted (#1) for review on release-3.8 by Niels de Vos (ndevos@redhat.com)

Comment 2 Vijay Bellur 2016-08-09 14:59:44 UTC
COMMIT: http://review.gluster.org/15115 committed in release-3.8 by Niels de Vos (ndevos@redhat.com) 
------
commit 7ba61c46164114d6cfd606a098b45aaf3eaa8773
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Jul 19 12:55:03 2016 +0200

    build: systemd unit should not be marked executable
    
    systemd complains about the unit for GlusterD when it is executable:
    
      Configuration file /usr/lib/systemd/system/glusterd.service is marked executable. Please remove executable permission bits. Proceeding anyway.
    
    The Makefile that installs the unit has some scripted commands. These
    are not needed and standard "*dir" and "*DATA" postfixes for variables
    can be used instead.
    
    The EXTRA_DIST variable is needed for building the 'make dist' tarball
    on systems where there is no systemd. The unit would be missing from the
    tarball if it is not explicitly included.
    
    Cherry picked from commit 9f22282795e20fd62b22847b92dffd0cde9cca1b:
    > BUG: 1354489
    > Change-Id: I5e72ec201036906b9b2458bc8931ccebf9a8c6b4
    > Reported-by: Sergej Pupykin <ml@sergej.pp.ru>
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: http://review.gluster.org/14892
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    
    Change-Id: I5e72ec201036906b9b2458bc8931ccebf9a8c6b4
    BUG: 1354499
    Reported-by: Sergej Pupykin <ml@sergej.pp.ru>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/15115
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Niels de Vos 2016-08-12 09:47:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.