Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354475 - ConfigMap not seen in oc get all and oc export all
Summary: ConfigMap not seen in oc get all and oc export all
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 12:01 UTC by Jaspreet Kaur
Modified: 2016-07-22 18:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-22 18:46:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1342606 None CLOSED oc delete all --all does not delete configmaps 2019-01-15 19:53:11 UTC

Internal Links: 1342606

Description Jaspreet Kaur 2016-07-11 12:01:11 UTC
Description of problem: When trying to export all objects in a namespace or all namespace it is observed that configMap is not seen in the output.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create configMap in one project
2. Export all objects of the namespace


oc export all \
    --exact \
    --all-namespaces \
    --as-template=cluster.template

3) Get all objects ;

oc get all


Actual results: ConfigMap not exported and not even seen in "oc get all"


Expected results: It should be successfully exported


Additional info:

Comment 1 Xingxing Xia 2016-07-12 01:20:46 UTC
The point is definition of "all" used in oc get/export/delete
Some discussion inf https://bugzilla.redhat.com/show_bug.cgi?id=1342606#c3

Comment 2 Fabiano Franz 2016-07-22 18:46:14 UTC
As per the following upstream discussion, ConfigMaps are not going to be added to 'all' because if deleted it's potentially unrecoverable:

https://github.com/kubernetes/kubernetes/pull/28955#issuecomment-232737113

Adding Clayton here to further comments if needed.


Note You need to log in before you can comment on or make changes to this bug.