Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354470 - QCI 1.2: Back button in browser breaks QCI product selection page - blank page is shown
Summary: QCI 1.2: Back button in browser breaks QCI product selection page - blank pag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 1.0
Assignee: cchase
QA Contact: bmorriso
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 11:52 UTC by Antonin Pagac
Modified: 2016-09-13 16:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-13 16:31:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1862 normal SHIPPED_LIVE Red Hat Quickstart Installer 1.0 2016-09-13 20:18:48 UTC

Internal Links: 1357900

Description Antonin Pagac 2016-07-11 11:52:44 UTC
Description of problem:
When you are starting new deployment and you are on the New Deployment page, when you select a product and click Next and then use the back button in your browser, an empty page is displayed instead of the product selection page. QCI menu seems not working, you can click on 'New Deployment' and also on 'Deployments' but blank page stays. Page refresh fixes this.
There is no error in production.log.

Version-Release number of selected component (if applicable):
20160708.t.0

How reproducible:
Always

Steps to Reproduce:
1. Have fresh install of QCI
2. Go to the New Deployment page, choose a product, click Next
3. Click the back button in your browser (not the one displayed on the page)
4. Blank page displayed; only header (satellite horizontal menu) is shown

Actual results:
Blank page displayed after using back button in browser

Expected results:
Product selection page should be shown

Additional info:
The 'Back' button shown on the page is working as expected. This issue happens only when you use the back function in your browser.

Comment 1 bmorriso 2016-07-11 19:02:07 UTC
Additional info:

I tested this with Firefox 47.0 and Chrome 51.0.2704.106 (64-bit), and the blank screen appears in both cases.

Comment 2 cchase 2016-07-18 14:50:25 UTC
Additional info:

Occurs on all QCI pages.

Comment 4 cchase 2016-07-19 13:32:38 UTC
https://github.com/fusor/fusor/pull/1054

Copied and modified the application.js file to turn off Rails turbolinks.

Comment 9 John Matthews 2016-07-20 22:52:50 UTC
QCI-1.2-RHEL-7-20160720.t.0-QCI-x86_64-dvd1.iso

Comment 10 cchase 2016-07-21 14:27:20 UTC
https://github.com/fusor/fusor/pull/1073

Added the application_no_tl.js to the engine.rb file for the iso environment.

Comment 14 cchase 2016-07-26 14:22:20 UTC
https://github.com/fusor/fusor/pull/1075
We were unable to build the modified application.js into the RPM.

https://github.com/fusor/fusor/pull/1090
Force Turbolinks to load the fusor javascript.  This page will still be blanked out, but then Ember will then load up the page appropriately.

Comment 15 John Matthews 2016-08-02 18:44:31 UTC
QCI-1.0-RHEL-7-20160801.t.2-QCI-x86_64-dvd1.iso

Comment 16 bmorriso 2016-08-10 18:20:17 UTC
Verified in compose QCI-1.0-RHEL-7-20160809.t.1

Following the reproduction steps in the description, this issue is no longer reproducible. Clicking the back button from the "1A. Deployment Name" page returns the user to the product selection page.

Comment 18 errata-xmlrpc 2016-09-13 16:31:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862


Note You need to log in before you can comment on or make changes to this bug.