Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354464 - [Ubuntu] installation of ceph-* packages fails because of old / not-synchronized package index
Summary: [Ubuntu] installation of ceph-* packages fails because of old / not-synchroni...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Gregory Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-07-11 11:42 UTC by Daniel Horák
Modified: 2016-07-12 14:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 14:08:24 UTC


Attachments (Terms of Use)
Failed ceph-installer tasks /api/mon/install and /api/osd/install (deleted)
2016-07-12 07:28 UTC, Daniel Horák
no flags Details

Description Daniel Horák 2016-07-11 11:42:52 UTC
Description of problem:
  Cluster creation fails on Ubuntu nodes with following error for each node:
    Package installation failed on HOSTNAME

  From skyring.log it is obvious that the problem is with installation of ceph-mon, ceph-osd and other related packages:
    msg: No package matching 'ceph-mon' is available

  The problem is, that appropriate repos are properly added to the nodes, but the package index is not refreshed by `apt-get update`.
  
  When I manually refresh the package index on each Ubuntu node by execution of `apt-get update` command, second try for cluster creation including package installation pass correctly.
  
Version-Release number of selected component (if applicable):
  USM server (RHEL 7.2):
  # rpm -qa | grep -e rhscon -e ceph
    rhscon-ui-0.0.46-1.el7scon.noarch
    ceph-installer-1.0.12-4.el7scon.noarch
    rhscon-core-selinux-0.0.32-1.el7scon.noarch
    rhscon-core-0.0.32-1.el7scon.x86_64
    rhscon-ceph-0.0.31-1.el7scon.x86_64
    ceph-ansible-1.0.5-25.el7scon.noarch

How reproducible:
  100%


Steps to Reproduce:
1. Prepare bunch of Ubuntu nodes and RHEL USM server.
2. Add appropriate repos to the Ubuntu nodes (correspondingly to the roles of the node - MON, OSD) and configure rhscon-agent accordingly to the documentation.
3. Try to create Ceph cluster.
4. Manually refresh the package index on all Ubuntu nodes (`apt-get update`).
5. Try to create Ceph cluster.


Actual results:
  Firstly cluster creation fails on all *Package installation* tasks on Ubuntu nodes.
  Second try of cluster creation pass, all packages are properly installed.

Expected results:
  It should refresh package index on Ubuntu index before installation any new package.
  

Additional info:
  Maybe it is bug for ceph-installer/ceph-ansible or just documentation issue, fell free to move this Bug to the appropriate component.

Comment 1 Alfredo Deza 2016-07-11 20:56:18 UTC
It is not clear where in ceph-ansible this is failing. The ceph-installer captures most information from requests (in this case from USM) and it is important we get this to get details and determine what is missing.

This is documented here: http://docs.ceph.com/ceph-installer/docs/#tasks

Could you create an attachment with the output of the failed task?

Comment 2 Daniel Horák 2016-07-12 07:28:16 UTC
Created attachment 1178768 [details]
Failed ceph-installer tasks /api/mon/install and /api/osd/install

Please find the log from failed tasks in attachment.

When I run `apt-get update` on each node and launch this tasks again, it works correctly.

Comment 3 Alfredo Deza 2016-07-12 13:06:57 UTC
You mention that you are doing this step:

> 2. Add appropriate repos to the Ubuntu nodes (correspondingly to the roles of > the node - MON, OSD) and configure rhscon-agent accordingly to the documentation.

But ceph-ansible is in charge of setting up repositories for you. Can you point out what documentation is telling you to add repositories manually?

The task will do `apt-get update` for you as long as the cache hasn't been updated in the past hour.

Comment 4 Daniel Horák 2016-07-12 14:08:24 UTC
With the explanation about cache expiration in previous comment and after check of documentation, where is `apt-get update` mentioned after adding any new repository, I'm closing this as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.