Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354437 - [Ubuntu] rhscon-agent/skynet logrotate config file name inconsistency
Summary: [Ubuntu] rhscon-agent/skynet logrotate config file name inconsistency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: agent
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Daniel Horák
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-07-11 10:17 UTC by Daniel Horák
Modified: 2016-08-23 19:56 UTC (History)
5 users (show)

Fixed In Version: rhscon-agent_0.0.14-2redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:56:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Daniel Horák 2016-07-11 10:17:51 UTC
Description of problem:
  Config file for logrotate for rhscon-agent (skynet) is named diferently on RHEL and on Ubuntu.

Version-Release number of selected component (if applicable):
  # rpm -q rhscon-agent
    rhscon-agent-0.0.13-1.el7scon.noarch
  
  # dpkg -l rhscon-agent
    rhscon-agent   0.0.11-2redhat1xenia all

How reproducible:
  100%

Steps to Reproduce:
1. List logrotate related configuration files from rhscon-agent package on Ubuntu and RHEL and compare them:
  Ubuntu:
  # dpkg -L rhscon-agent | grep logrotate
  RHEL:
  # rpm -ql rhscon-agent | grep logrotate

Actual results:
  Ubuntu:
  # dpkg -L rhscon-agent | grep logrotate
  /etc/logrotate.d/skynet

  RHEL:
  # rpm -ql rhscon-agent | grep logrotate
  /etc/logrotate.d/rhscon-agent

Expected results:
  The logrotate configuration file in downstream package should be named "rhscon-agent" and not skynet.

Comment 4 Daniel Horák 2016-07-28 11:10:38 UTC
The logrotate configuration file in downstream package is properly named "rhscon-agent" now.

# dpkg -L rhscon-agent | grep logrotate
  /etc/logrotate.d
  /etc/logrotate.d/rhscon-agent

Tested on:
  rhscon-agent 0.0.16-2redhat1xenial

Comment 6 errata-xmlrpc 2016-08-23 19:56:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.