Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354434 - [Ubuntu] rhscon-agent: missing skynet configuration, useless skyring configuration files
Summary: [Ubuntu] rhscon-agent: missing skynet configuration, useless skyring configur...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: distribution
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Daniel Horák
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 10:08 UTC by Daniel Horák
Modified: 2016-08-23 19:56 UTC (History)
3 users (show)

Fixed In Version: rhscon-agent_0.0.15-2redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:56:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Daniel Horák 2016-07-11 10:08:38 UTC
Description of problem:
  Ubuntu version of rhscon-agent packages doesn't contain skynet configuration and instead contains useless skyring configuration.

Version-Release number of selected component (if applicable):
  rhscon-agent 0.0.11-2redhat1xenial

How reproducible:
  100%

Steps to Reproduce:
1. Install rhscon-agent on Ubuntu.
2. List files from rhscon-agent package:
  # dpkg -L rhscon-agent 
3. Compare the list with list of files from rhel version:
  # rpm -ql rhscon-agent

Actual results:
  Package rhscon-agent on Ubuntu doesn't contain /etc/skynet/* configuration files and contains /etc/skyring/:
  ~~~~~~~~~~~~~~~~~~~~~~~~
  # dpkg -L rhscon-agent | grep etc
  /etc
  /etc/logrotate.d
  /etc/logrotate.d/skynet
  /etc/sudoers.d
  /etc/sudoers.d/skynet
  /etc/skyring
  /etc/skyring/skyring.conf
  /etc/skyring/skyring-log.conf
  ~~~~~~~~~~~~~~~~~~~~~~~~
  
  This is similar output for RHEL version of rhscon-agent package for reference:
  ~~~~~~~~~~~~~~~~~~~~~~~~
  # rpm -ql rhscon-agent | grep etc
  /etc/logrotate.d/rhscon-agent
  /etc/skynet
  /etc/skynet/skynet-log.conf
  /etc/skynet/skynet.conf
  ~~~~~~~~~~~~~~~~~~~~~~~~

Expected results:
  rhscon-agent package on Ubuntu should contain all required files (as on  RHEL) and should not contain any useless files.

Additional info:
  Service skynetd crash with following lines in log:
  ~~~~~~~~~~~~~~~~~~~~~~~~
  # cat /var/log/skynet/skynet.log 
  2016-07-11 08:45:43,551 - INFO - skynetd: Initializing skynetd
  2016-07-11 08:45:43,774 - ERROR - skynetd: Configuration file: /etc/skynet/skynet.conf could not be read
  ~~~~~~~~~~~~~~~~~~~~~~~~

Comment 8 Daniel Horák 2016-07-28 11:08:32 UTC
Package rhscon-agent on Ubuntu now contains all required files (as on  RHEL) and no useless files as previously.

Tested on:
  rhscon-agent 0.0.16-2redhat1xenial

>> VERIFIED

Comment 10 errata-xmlrpc 2016-08-23 19:56:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.