Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354431 - iscsi-initiator-utils python module not works.
Summary: iscsi-initiator-utils python module not works.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 7.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Chris Leech
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 10:00 UTC by Gris Ge
Modified: 2016-07-21 05:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-21 05:35:06 UTC


Attachments (Terms of Use)

Description Gris Ge 2016-07-11 10:00:44 UTC
Description of problem:

[fge@el7r ~]$  python2 -c 'import libiscsimodule'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: dynamic module does not define init function (initlibiscsimodule)


Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.873-34.el7.x86_64 (RHEL 7.3)
and
iscsi-initiator-utils-6.2.0.873-33.el7.x86_64 (RHEL 7.2)

How reproducible:
100%

Steps to Reproduce:
1. Install iscsi-initiator-utils
2. Execute `python2 -c 'import libiscsimodule'`

Actual results:
Failure.

Expected results:
Pass

Additional info:
As this is not upstream feature, no sure it's supported or not.

Comment 1 Bruno Goncalves 2016-07-11 14:17:09 UTC
It seems you should use: python2 -c'import libiscsi'

python2 -v -c'import libiscsi'
<snip>
import libiscsi # dynamically loaded from /usr/lib64/python2.7/site-packages/libiscsimodule.so

# rpm -q iscsi-initiator-utils
iscsi-initiator-utils-6.2.0.873-34.el7.x86_64

Comment 2 Gris Ge 2016-07-21 05:35:06 UTC
Thank Bruno.
Closed as not a bug.


Note You need to log in before you can comment on or make changes to this bug.