Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354429 - [Bitrot] Need a way to set scrub interval to a minute, for ease of testing
Summary: [Bitrot] Need a way to set scrub interval to a minute, for ease of testing
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: bitrot
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
bugs@gluster.org
URL:
Whiteboard:
Depends On: 1337391 1351537 1354425
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:56 UTC by Kotresh HR
Modified: 2016-08-12 09:47 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1354425
Environment:
Last Closed: 2016-08-12 09:47:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2016-07-11 09:56:15 UTC
+++ This bug was initially created as a clone of Bug #1354425 +++

+++ This bug was initially created as a clone of Bug #1351537 +++

+++ This bug was initially created as a clone of Bug #1337391 +++

Description of problem:
========================
Currently, the command 'gluster volume bitrot <volname> scrub-frequency' can set the frequency to hourly/daily/weekly/biweekly/monthly. For testing, we set the frequency to the minimum possible, i.e., an hour. After corrupting a file,  we are forced to wait out an entire hour (or more) for the scrubber to mark the file as 'corrupted'. The above mentioned step is one of the common task that is followed for most test cases. 

This leads to unnecessary inconvenience when testing bitrot feature. Needless to say, automation also takes close to 3 days, just because of the mandatory requirement of waiting for an hour before doing any validation. I understand the need to reduce time < hour would never arise in the field, but it would be good to have such an option provided for testing and regression purposes, in the upcoming releases. 


Version-Release number of selected component (if applicable):
============================================================


Additional info:
================
[root@dhcp35-13 ~]# gluster v bitrot ozone 
Usage: volume bitrot <VOLNAME> {enable|disable} |
volume bitrot <volname> scrub-throttle {lazy|normal|aggressive} |
volume bitrot <volname> scrub-frequency {hourly|daily|weekly|biweekly|monthly} |
volume bitrot <volname> scrub {pause|resume|status}

Comment 1 Vijay Bellur 2016-07-11 09:57:21 UTC
REVIEW: http://review.gluster.org/14890 (features/bitrot: Option to set scrub interval to a minute) posted (#1) for review on release-3.8 by Kotresh HR (khiremat@redhat.com)

Comment 2 Vijay Bellur 2016-07-15 13:43:00 UTC
COMMIT: http://review.gluster.org/14890 committed in release-3.8 by Jeff Darcy (jdarcy@redhat.com) 
------
commit 09678a68a323b3873c8f8fe24d42e14294e0034c
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Jun 30 14:49:51 2016 +0530

    features/bitrot: Option to set scrub interval to a minute
    
    Backport of http://review.gluster.org/14836/
    
    Bitrot scrub-frequency supports "hourly|daily|weekly|biweekly|monthly".
    But it is painful for testing as minimum  scrub-interval is an hour
    Hence introducing a scrub interval of minute to ease testing.
    It is intentionally not exposed in bitrot command help as it is
    only for testing.
    
    e.g.,
    gluster vol bitrot <volname> scrub-frequency minute
    
    Change-Id: I155a65298d3fad5ae9e529d9c7d4b0d25fa297c0
    BUG: 1354429
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/14836
    (cherry picked from commit 7df1174f7bed2a00631cf17201f5217a053afeb1)
    Reviewed-on: http://review.gluster.org/14890
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 3 Niels de Vos 2016-08-12 09:47:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.