Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354427 - [es, fr, pt] login form fields get truncated
Summary: [es, fr, pt] login form fields get truncated
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: All
OS: Linux
low
low vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Greg Sheremeta
QA Contact: Yuko Katabami
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:54 UTC by Bhushan Barve
Modified: 2019-01-10 12:42 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.3.0_rc
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-12-10 01:24:03 UTC
oVirt Team: UX
rule-engine: ovirt-4.3+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
ja_JP_profile (deleted)
2016-07-11 09:54 UTC, Bhushan Barve
no flags Details
looks good in 4.2 (deleted)
2017-11-30 15:17 UTC, Greg Sheremeta
no flags Details
ja_JP_login_4.2 (deleted)
2017-12-15 09:29 UTC, Bhushan Barve
no flags Details
es_ES_login_overlap_4.2.2.4 (deleted)
2018-03-16 09:58 UTC, Bhushan Barve
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1549486 None NEW [RFE] update login page to match new PatternFly login design 2019-01-10 12:41:58 UTC
oVirt gerrit 88213 master MERGED engine: set nowrap on login form labels 2018-02-27 13:56:49 UTC
oVirt gerrit 88274 ovirt-engine-4.2 MERGED engine: set nowrap on login form labels 2018-02-28 09:52:33 UTC

Internal Links: 1549486

Description Bhushan Barve 2016-07-11 09:54:35 UTC
Created attachment 1178328 [details]
ja_JP_profile

Description of problem: As per the translator's comment in the tcms, the Japanese translation for "Profile" on the login screen is broken into two lines. It would be better if the width can be extended to fit this string in a single line. Screenshot attached. 


Version-Release number of selected component (if applicable):
 Red Hat Enterprise Virtualization Manager バージョン: 4.0.2-0.2.rc1.el7ev 

How reproducible:
always

Steps to Reproduce:
1. launch ovirt-engine page and select locale as ja_JP
2. go to admin portal login screen.
3. observe the string 'profile'

Actual results:
The string appears on two lines.

Expected results:
The string should appear in one single line only.

Additional info:

Comment 1 Bhushan Barve 2017-02-03 09:32:50 UTC
The bug is reproducible in 4.1.0.3-0.1.el7. Changing the version accordingly.

Comment 2 Greg Sheremeta 2017-11-30 15:16:53 UTC
At 1920x1080 resolution, it doesn't wrap in 4.2. Moving to MODIFIED.

Upon shrinking the windows, eventually all of the fields wrap. That's by design, although I may be able to improve it in 4.3.

Comment 3 Greg Sheremeta 2017-11-30 15:17:25 UTC
Created attachment 1360971 [details]
looks good in 4.2

Comment 4 RHV Bugzilla Automation and Verification Bot 2017-12-06 15:59:51 UTC
Not sure how this is on MODIFIED if there is no code change/tracker attached.
Shouldn't you close it or move it to assigned and 4.3?

Comment 5 RHV Bugzilla Automation and Verification Bot 2017-12-06 16:15:49 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[No external trackers attached]

For more info please contact: infra@ovirt.org

Comment 6 Greg Sheremeta 2017-12-06 18:10:42 UTC
It's something that was accidentally fixed in 4.2, and I'm not sure when, thus no patch number. I still want QE to look at it, so I'm not going to close it.

Comment 7 Bhushan Barve 2017-12-15 09:28:39 UTC
(In reply to Greg Sheremeta from comment #6)
> It's something that was accidentally fixed in 4.2, and I'm not sure when,
> thus no patch number. I still want QE to look at it, so I'm not going to
> close it.

Hi Greg, I checked with Version:4.2.0-0.6.el7 on desktop monitor(22", max resolution available: 1680 X 1050). For ja_JP, the profile field still looks same as mentioned in this bug. Please refer attached screenshot. So please let me know if it can be improved in 4.3

Comment 8 Bhushan Barve 2017-12-15 09:29:12 UTC
Created attachment 1368416 [details]
ja_JP_login_4.2

Comment 9 Yaniv Kaul 2018-02-19 08:59:40 UTC
Greg, why is it pushed to 4.3.0?

Comment 10 Greg Sheremeta 2018-03-10 13:28:33 UTC
Hi, can you retest?

Comment 11 Bhushan Barve 2018-03-16 09:57:24 UTC
Checked with 4.2.2.4-0.1.el7

The text alignment looks fine now for ja_JP. However I've observed for fr, es and pt_BR that, the label 'username' gets overlapped by the text field. So just want to confirm whether it's a regression of this fix or should close this issue and file a new one for tracking it? Please check attached screenshot for es_ES as reference.

Comment 12 Bhushan Barve 2018-03-16 09:58:20 UTC
Created attachment 1408707 [details]
es_ES_login_overlap_4.2.2.4

Comment 13 Greg Sheremeta 2018-03-21 12:54:40 UTC
Thanks Bhushan. It could be a regression. I'm not going to fix it directly, because we're redoing the login page for 4.3 and the new design won't have this issue. See: https://bugzilla.redhat.com/show_bug.cgi?id=1549486

and

https://github.com/patternfly/patternfly-design/blob/master/pattern-library/application-framework/login-page/design/design.md

No need to open a new bug -- I'll just more this to 4.3.

Comment 14 Greg Sheremeta 2018-12-10 01:24:03 UTC
Unfortunately we do not have capacity to work on this.


Note You need to log in before you can comment on or make changes to this bug.