Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354421 - Error message prompts when removing the physical volume from the volume group.
Summary: Error message prompts when removing the physical volume from the volume group.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: pre-dev-freeze
: ---
Assignee: Dominik Perpeet
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: ovirt-node-ng-platform
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:48 UTC by Wei Wang
Modified: 2016-11-04 09:05 UTC (History)
13 users (show)

Fixed In Version: cockpit-118-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 09:05:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error message picture (deleted)
2016-07-11 09:48 UTC, Wei Wang
no flags Details
ks file (deleted)
2016-07-11 09:48 UTC, Wei Wang
no flags Details
log files (deleted)
2016-07-11 09:50 UTC, Wei Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2624 normal SHIPPED_LIVE cockpit bug fix and enhancement update 2016-11-03 18:16:32 UTC

Description Wei Wang 2016-07-11 09:48:15 UTC
Created attachment 1178324 [details]
Error message picture

Description of problem:
Error message prompts when removing the physical volume from the volume group.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160708.0.x86_64
imgbased-0.7.2-0.1.el7ev.noarch
cockpit-0.108-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Interactive install redhat-virtualization-host-4.0-20160708.0.x86_64 with kickstart file in attachment
    Using part disk manually, and make some disk spaces not parted.
2. Login cockpit website hostIP:9090 with root account
3. Select the disk in cockpit storage page, and create 2 or more partition.
4. Create PVs using the partition in steps 3 on host console.
5. In cockpit, add volume group with PVs in Steps 4
6. Select the added volume group to list the physical volumes
7. Click remove button for every physical volume

Actual results:
Error message prompts when removing the physical volume from the volume group.

Expected results:
All the physical volumes can be removed successfully

Additional info: 
When removing the last physical volume(2 PVs for the VG), the bug occurs.

Comment 1 Wei Wang 2016-07-11 09:48:54 UTC
Created attachment 1178325 [details]
ks file

Comment 2 Wei Wang 2016-07-11 09:50:10 UTC
Created attachment 1178326 [details]
log files

Comment 3 Doron Fediuck 2016-07-12 11:57:45 UTC
Did the action succeed?
If not the problem is with the failure and not with the UI.

Comment 4 Wei Wang 2016-07-13 02:01:24 UTC
Doron,
After the error message is displayed, click the "Close" button, the physical volume cannot removed successfully. It still be there.

Comment 5 Fabian Deutsch 2016-07-18 15:03:18 UTC
This looks like a cockpit issue, moving it over.

Comment 6 Dominik Perpeet 2016-07-18 19:37:01 UTC
Apparently the volume group can't be empty.

We can either disable the remove button for the last device or offer to delete the entire group. What is the desired behavior here?

Note that the same thing happens when trying to delete the last disk from a RAID.

Comment 8 Marius Vollmer 2016-08-03 12:40:51 UTC
We should disable the "Remove" button with a tooltip describing the reason.

Comment 9 Marius Vollmer 2016-08-04 10:07:12 UTC
Here is a PR with a different approach: https://github.com/cockpit-project/cockpit/pull/4822

Comment 11 errata-xmlrpc 2016-11-04 09:05:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2624.html


Note You need to log in before you can comment on or make changes to this bug.