Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354416 - [RFE]Shouldn't map win8.1 to win8 because they belong to different version number
Summary: [RFE]Shouldn't map win8.1 to win8 because they belong to different version nu...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 4.0.0
Hardware: All
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Scott Herold
QA Contact: Gil Klein
URL:
Whiteboard:
Depends On:
Blocks: 1354509
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:38 UTC by mxie@redhat.com
Modified: 2016-11-21 13:39 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-21 13:39:31 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)
screenshot (deleted)
2016-07-11 09:38 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2016-07-11 09:38:49 UTC
Created attachment 1178323 [details]
screenshot

Description of problem:
Shouldn't map win8.1 to win8 because they belong to different version number

Version-Release number of selected component (if applicable):
rhevm:4.0.0.6-0.1.el7ev

How reproducible:
100%

Steps to Reproduce:
1.Import guest from vmware at rhevm GUI
login rhevm4.0->Virtual Machines->Import->Select 'VMware'as source-> input vmware info-> select the host which is virt-v2v conversion server ->load vms -> select a guest->click import

2.At guest import dialog, there is no win8.1 type in operating system option, pls refer to screenshot1

Actual results:
As above description

Expected results:
Should add win8.1 type in in operating system option, because win8.1 belongs to 6.3 version but win8 belongs to 6.2 version, there is necessary to distinguish them in rhevm

Additional info:

Comment 3 Michal Skrivanek 2016-09-08 13:35:44 UTC
I don't understand the request. By default we do not add new OS types unless there is a need for differentiation.
Please add some reasoning why to do it

Comment 4 Richard W.M. Jones 2016-09-08 14:04:55 UTC
The issue, if it is such, is that virt-v2v puts the guest type
intothe OVF <ovf:OperatingSystemSection_Type> field:

https://github.com/libguestfs/libguestfs/blob/master/v2v/OVF.ml#L77

Currently for Windows internal version 6.3 (Win8.1) it puts
"windows_8" or other variations into that field:

https://github.com/libguestfs/libguestfs/blob/master/v2v/OVF.ml#L157

As a result of this when you import a guest into RHEV, you will
see Windows 8 being displayed instead of 8.1, and hence a bug
was filed against virt-v2v (RHBZ#130958), which is unfixable in
virt-v2v.

What would be nicer would be if we could pass over the inspection
data to RHEV more directly, rather than having all this mapping
business.  Refer to:

http://libguestfs.org/guestfs.3.html#inspection
http://libguestfs.org/guestfs.3.html#guestfs_inspect_get_arch

Comment 5 Michal Skrivanek 2016-09-09 07:13:44 UTC
the simplified mapping needs to happen somewhere. We do not want to go into more detailed differentiation than necessary in oVirt.
It wouldn't be a problem to do that on oVirt side if we can find the true state of things somehow. It would be the same mapping, but it does make a bit more sense to maintain it in the same component which defines those types.

Not sure if there is an easy way how to do that though. I'm not even sure if it's needed either. AFAIK we are not using it in the probe phase (we use libvirt information for VMware provider and just few things from the general VM description(e.g. a name) and disk&nic infos. 
Correctness of that OperatingSystemSection_Type field matters only when using virt-v2v on command line and then importing it to oVirt manually
Maybe we can simplify things and hardcode just a basic Windows/Linux types into virt-v2v and leave the rest on user, or on oVirt eventually if/when we do the inspection.

Regardless all that, the bug does not really make much sense as there is simply no Windows 8.1 type in oVirt and we do not plan to add it unless there is a good reason.

Comment 6 Michal Skrivanek 2016-10-12 09:59:06 UTC
I'm suggesting to close this. Moran?

Comment 7 Moran Goldboim 2016-10-27 10:24:38 UTC
(In reply to Michal Skrivanek from comment #6)
> I'm suggesting to close this. Moran?

we aren't going into that granularity of minor releases even for RHEL versions.
nevertheless, it would be interesting to allow the guest agent to update the OS type automatically.

ack from my side to close it.

Comment 8 Michal Skrivanek 2016-11-21 13:39:31 UTC
not relevant at the moment. We do not plan to add every operating system, not until there is some differentiation in how we configure it.
Might reevaluate when/if we do deeper integration with libosinfo, but that's far away


Note You need to log in before you can comment on or make changes to this bug.