Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354414 - New or modified ID-View User overrides are not visible unless rm -f /var/lib/sss/db/*cache*
Summary: New or modified ID-View User overrides are not visible unless rm -f /var/lib/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Steeve Goveas
URL:
Whiteboard:
Depends On:
Blocks: 1440193
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:35 UTC by Luc de Louw
Modified: 2017-04-07 14:17 UTC (History)
8 users (show)

Fixed In Version: sssd-1.14.0-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1440193 (view as bug list)
Environment:
Last Closed: 2016-11-04 07:19:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2476 normal SHIPPED_LIVE sssd bug fix and enhancement update 2016-11-03 14:08:11 UTC

Description Luc de Louw 2016-07-11 09:35:18 UTC
Description of problem:
When adding a new Override or modifying an existing one in IPAs ID-View, the changes are not visible to the systems in question. 

Version-Release number of selected component (if applicable):
sssd-1.13.0-40.el7_2.9

How reproducible:
Always

Steps to Reproduce:
1.id tester
uid=1001(tester) gid=1002 groups=1002,94800003(satorgadmin),94800008(oradba)
2. Change User override in IPA
3. sss_cache -E && systemctl restart sssd
4. id tester
uid=1001(tester) gid=1002 groups=1002,94800003(satorgadmin),94800008(oradba)


Actual results:
See Steps to Reproduce


Expected results:

ID-View Overrides changes should be visible ideally instantly or within a defined timeframe 


Additional info:

As a workaround one can remove the cache files:
# systemctl stop sssd
# rm -f /var/lib/sss/db/*cache*
# systemctl start sssd

Comment 1 Sumit Bose 2016-07-11 11:00:15 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/3092

Comment 5 Varun Mylaraiah 2016-09-22 10:01:50 UTC
Verified 
sssd-1.14.0-42.el7.x86_64
ipa-server-4.4.0-12.el7.x86_64

[root@host108 ~]# id aduser99@ipaad2008r2.test
uid=175005770(aduser99@ipaad2008r2.test) gid=175005770(aduser99@ipaad2008r2.test) groups=175005770(aduser99@ipaad2008r2.test)
[root@host108 ~]# ipa idoverrideuser-add
ID View Name: Default Trust View
Anchor to override: aduser99@ipaad2008r2.test
--------------------------------------------------
Added User ID override "aduser99@ipaad2008r2.test"
--------------------------------------------------
  Anchor to override: aduser99@ipaad2008r2.test
  
[root@host108 ~]# ipa idoverrideuser-mod --uid=175005555
ID View Name: Default Trust View
Anchor to override: aduser99@ipaad2008r2.test
--------------------------------------------------------
Modified an User ID override "aduser99@ipaad2008r2.test"
--------------------------------------------------------
  Anchor to override: aduser99@ipaad2008r2.test
  UID: 175005555

[root@host108 ~]# sss_cache -E && systemctl restart sssd
[root@host108 ~]# 
[root@host108 ~]# id aduser99@ipaad2008r2.test
uid=175005555(aduser99@ipaad2008r2.test) gid=175005770(aduser99@ipaad2008r2.test) groups=175005770(aduser99@ipaad2008r2.test)

Comment 7 errata-xmlrpc 2016-11-04 07:19:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2476.html


Note You need to log in before you can comment on or make changes to this bug.