Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354406 - host-del updatedns options complains about missing ptr record for host
Summary: host-del updatedns options complains about missing ptr record for host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:13 UTC by Kaleem
Modified: 2016-11-04 05:57 UTC (History)
4 users (show)

Fixed In Version: ipa-4.4.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:57:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Kaleem 2016-07-11 09:13:43 UTC
Description of problem:

When --updatedns used along with host-del, it complains about missing ptr record for host which exists.


Version-Release number of selected component (if applicable):
[root@dhcp207-129 ~]# rpm -q ipa-server ipa-server-dns
ipa-server-4.4.0-1.el7.x86_64
ipa-server-dns-4.4.0-1.el7.noarch
[root@dhcp207-129 ~]#

How reproducible:
Always

Steps to Reproduce:
[root@dhcp207-129 ~]# ipa host-add --ip-address=10.65.207.99 myhost.testrelm.test
---------------------------------
Added host "myhost.testrelm.test"
---------------------------------
  Host name: myhost.testrelm.test
  Principal name: host/myhost.testrelm.test@TESTRELM.TEST
  Principal alias: host/myhost.testrelm.test@TESTRELM.TEST
  Password: False
  Keytab: False
  Managed by: myhost.testrelm.test
[root@dhcp207-129 ~]# ipa host-show myhost.testrelm.test
  Host name: myhost.testrelm.test
  Principal name: host/myhost.testrelm.test@TESTRELM.TEST
  Principal alias: host/myhost.testrelm.test@TESTRELM.TEST
  Password: False
  Keytab: False
  Managed by: myhost.testrelm.test
[root@dhcp207-129 ~]# ipa dnsrecord-find testrelm.test myhost
  Record name: myhost
  A record: 10.65.207.99
----------------------------
Number of entries returned 1
----------------------------
[root@dhcp207-129 ~]# ipa dnsrecord-find 207.65.10.in-addr.arpa. 99
  Record name: 99
  PTR record: myhost.testrelm.test.
----------------------------
Number of entries returned 1
----------------------------
[root@dhcp207-129 ~]# ipa host-del --updatedns myhost.testrelm.test
ipa: ERROR: PTR record does not contain 'myhost.testrelm.test'
[root@dhcp207-129 ~]#

Actual results:
host not deleted

Expected results:
host should have been deleted along with dns records in forward/reverse zones.

Comment 3 Petr Vobornik 2016-07-12 15:50:44 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6060

Comment 4 Martin Bašti 2016-07-22 11:41:01 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/8aba4f63439853d524e8b394b7919159c86d2a08

Comment 6 Kaleem 2016-08-03 13:02:02 UTC
Verified.

[root@dhcp207-129 ~]# ipa host-add --ip-address=10.65.207.99 myhost.testrelm.test
---------------------------------
Added host "myhost.testrelm.test"
---------------------------------
  Host name: myhost.testrelm.test
  Principal name: host/myhost.testrelm.test@TESTRELM.TEST
  Principal alias: host/myhost.testrelm.test@TESTRELM.TEST
  Password: False
  Keytab: False
  Managed by: myhost.testrelm.test
[root@dhcp207-129 ~]# ipa dnsrecord-find testrelm.test myhost

  Record name: myhost
  A record: 10.65.207.99
----------------------------
Number of entries returned 1
----------------------------
[root@dhcp207-129 ~]# ipa dnsrecord-find 207.65.10.in-addr.arpa. 99
  Record name: 99
  PTR record: myhost.testrelm.test.
----------------------------
Number of entries returned 1
----------------------------
[root@dhcp207-129 ~]# ipa host-del --updatedns myhost.testrelm.test
-----------------------------------
Deleted host "myhost.testrelm.test"
-----------------------------------
[root@dhcp207-129 ~]# ipa dnsrecord-find testrelm.test myhost
----------------------------
Number of entries returned 0
----------------------------
[root@dhcp207-129 ~]# ipa dnsrecord-find 207.65.10.in-addr.arpa. 99
----------------------------
Number of entries returned 0
----------------------------
[root@dhcp207-129 ~]#
[root@dhcp207-129 ~]# rpm -q ipa-server
ipa-server-4.4.0-4.el7.x86_64
[root@dhcp207-129 ~]#

Comment 8 errata-xmlrpc 2016-11-04 05:57:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.