Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354401 - Heapster pod continued in stating tons of lines "The labelNodeId was set to but there is no label with this value.Using the default 'nodename' label instead" in its log
Summary: Heapster pod continued in stating tons of lines "The labelNodeId was set to ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Matt Wringe
QA Contact: chunchen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 09:06 UTC by Xia Zhao
Modified: 2016-09-30 02:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-06 19:49:28 UTC


Attachments (Terms of Use)

Comment 1 Matt Wringe 2016-07-11 14:08:40 UTC
I know why this is happening, but I can't exactly reproduce it on my system locally.

docker images:
registry.access.redhat.com/openshift3/metrics-heapster:3.1.1 (b656a9a1e370)
registry.access.redhat.com/openshift3/metrics-hawkular-metrics:3.1.1 (365e3bab3c13)
registry.access.redhat.com/openshift3/metrics-cassandra:3.1.1 (b8b230cdea46)
registry.access.redhat.com/openshift3/metrics-deployer:3.1.1 (684da28d42f4)

Using this as the metrics.yaml: https://github.com/openshift/origin-metrics/blob/ose-v1.1/metrics.yaml

But, I tried this on an origin system and not on OSE 3.1, so that might be where the issue is occurring. It also looks like I might be using a different deployer, are you using the latest 3.1.1 deployer image? or an older one?

This should probably be a quick fix to change the logging level in one of our patches to better match how its being handled upstream in more recent versions.


Note You need to log in before you can comment on or make changes to this bug.