Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354392 - [rfe] versionlock is too simple
Summary: [rfe] versionlock is too simple
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 08:34 UTC by Cristian Morales Vega
Modified: 2017-06-08 14:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-08 14:30:11 UTC


Attachments (Terms of Use)

Description Cristian Morales Vega 2016-07-11 08:34:33 UTC
The current Wireshark package has a bug that affects me. Because of that I don't want to install it, and I'm staying with the current version. That doesn't mean I want to stay with the current version forever, it just means I don't want to install the currently available update. I don't want to lock the current version installed, I want to lock the currently available update uninstalled. Whenever a new version is available I want to install it, to test if the bug affecting me has been fixed.

Right now I simply want to be able to lock a single package version in an uninstalled state. But ideally versionlock would offer a syntax as verbose as the one offered by libzypp: https://github.com/openSUSE/libzypp/blob/master/doc/locks.5.txt

Comment 1 Fedora Admin XMLRPC Client 2016-07-21 12:41:30 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Jaroslav Mracek 2017-06-08 14:30:11 UTC
If I good understand your request you want to exclude from install or upgrade some special version of package (like Wireshark-454.5-5). Then you can use versionlock like ``dnf versionlock exclude Wireshark-454.5-5`` then the package will be not present in any transaction.
Anyway I improved documentation (https://github.com/rpm-software-management/dnf-plugins-core/pull/223) that should better explain functionality.
From my point of view the problem was only in documentation, but please if you will find my explanation insufficient, please don't hesitate to reopen the bug report with additional information.


Note You need to log in before you can comment on or make changes to this bug.