Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354372 - Fix timing issue in tests/bugs/glusterd/bug-963541.t
Summary: Fix timing issue in tests/bugs/glusterd/bug-963541.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1355610 1375049
TreeView+ depends on / blocked
 
Reported: 2016-07-11 07:49 UTC by Sakshi
Modified: 2017-03-27 18:20 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1355610 1375049 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:20:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sakshi 2016-07-11 07:49:58 UTC
Description of problem:
Start and stop rebalance, but the stop command fails as by that time the rebalance process has not come up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:


Additional info:
RCA: on starting rebalance, the process had not come up because glusterd spawns it with nowait from runner interface. So the rebalance stop issued fails

Comment 1 Vijay Bellur 2016-07-11 08:07:44 UTC
REVIEW: http://review.gluster.org/14885 (tests: fix rebalance timing issue) posted (#1) for review on master by Sakshi Bansal

Comment 2 Vijay Bellur 2016-07-11 14:05:01 UTC
COMMIT: http://review.gluster.org/14885 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit bfbadab0d65f38d2719ceb4d5c9144377db9d4d5
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Mon Jul 11 13:34:28 2016 +0530

    tests: fix rebalance timing issue
    
    With a start and stop rebalance, the stop command may fail
    as by that time the rebalance process may not come up.
    Using the rebalance status commmand to ensure that the rebalance
    process is up before stoping rebalance.
    
    Change-Id: I3d5123cd5dfabde2720428455b257d11b980ce21
    BUG: 1354372
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/14885
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:20:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.