Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354343 - [RFE] Add support for post copy migration (tech preview)
Summary: [RFE] Add support for post copy migration (tech preview)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.1.0-beta
: 4.1.0.2
Assignee: Milan Zamazal
QA Contact: Israel Pinto
URL:
Whiteboard:
: 1374760 (view as bug list)
Depends On: 1336709 1509920 1673043 migration_improvements 1374718
Blocks: 1430234
TreeView+ depends on / blocked
 
Reported: 2016-07-11 07:28 UTC by Tomas Jelinek
Modified: 2019-02-06 14:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update includes the Post-copy migration policy, which is available as a Technology Preview feature. The policy is similar to the Minimal Downtime policy, and enables the virtual machine to start running on the destination host as soon as possible. During the final phase of the migration (post-copy phase), the missing parts of the memory content is transferred between the hosts on demand. This guarantees that the migration will eventually converge with very little downtime. The disadvantage of this policy is that in the post-copy phase, the virtual machine may slow down significantly as the missing parts of memory are transferred between the hosts. If anything goes wrong during the post-copy phase, such as a network failure between the hosts, then the running virtual machine instance will be lost. It is therefore not possible to abort a migration during the post-copy phase.
Clone Of:
Environment:
Last Closed: 2017-02-15 15:06:26 UTC
oVirt Team: Virt
tjelinek: ovirt-4.1?
ipinto: testing_plan_complete+
tjelinek: planning_ack?
tjelinek: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 62873 master MERGED virt: Initial support for post-copy migration 2016-11-22 20:48:16 UTC
oVirt gerrit 63551 master MERGED virt: Start all VM related stuff after switching to post-copy migration 2016-11-22 20:48:20 UTC
oVirt gerrit 63552 master MERGED virt: Fetch only minimum VM stats during post-copy migration 2016-11-22 20:48:11 UTC
oVirt gerrit 63553 master MERGED virt: Use a variable for self._vm in MonitorThread action handling 2016-11-22 20:48:07 UTC
oVirt gerrit 63554 master MERGED virt: Log post-copy migration cancellation failure 2016-11-22 20:47:45 UTC
oVirt gerrit 64142 master MERGED virt: Destroy VM after post-copy migration failure 2016-12-02 16:37:10 UTC
oVirt gerrit 64143 master MERGED virt: Distinguish between switching to and entering post-copy migration 2016-11-22 20:48:02 UTC
oVirt gerrit 64144 master MERGED virt: Report downtime after a post-copy migration 2016-11-22 21:26:47 UTC
oVirt gerrit 64145 master MERGED virt: Stop guest agent before switching to post-copy 2016-11-22 20:47:53 UTC
oVirt gerrit 64146 master MERGED virt: Prevent monitoring of VMs in post-copy 2016-11-22 20:47:49 UTC
oVirt gerrit 64147 master MERGED virt: Report paused VM status in post-copy 2016-11-22 20:47:37 UTC
oVirt gerrit 64148 master MERGED virt: Destroy VM after a successful post-copy migration 2016-12-02 09:41:45 UTC
oVirt gerrit 64149 master MERGED virt: Inform Engine about switching to post-copy 2016-11-22 21:26:42 UTC
oVirt gerrit 66056 master MERGED virt: Move migration.py to lib/vdsm/ 2016-11-22 20:47:57 UTC
oVirt gerrit 67499 master MERGED virt: Prevent hook races after a successful migration 2016-12-02 09:13:09 UTC

Description Tomas Jelinek 2016-07-11 07:28:44 UTC
Support for post-copy live migration needs to be added. The task includes:
- enriching the the convergence schedule on VDSM to support "switch to postcopy"
- enriching the migration policies on engine to support "switch to post copy"
- making sure the monitoring code in engine will handle this switch properly (e.g. the VM is suddenly UP on the destination and DOWN on source, it was migrating but it does not mean that the migration is over yet)

Comment 1 Michal Skrivanek 2016-12-01 10:35:29 UTC
*** Bug 1374760 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.