Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354337 - [RFE] A faster and undisruptive satellite DR needed
Summary: [RFE] A faster and undisruptive satellite DR needed
Keywords:
Status: CLOSED DUPLICATE of bug 1284686
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Backup & Restore
Version: 6.1.9
Hardware: Unspecified
OS: Unspecified
medium
unspecified vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Sat6_HA_Tracker
TreeView+ depends on / blocked
 
Reported: 2016-07-11 07:13 UTC by Benjamin Chardi
Modified: 2017-04-25 16:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-03 20:05:48 UTC


Attachments (Terms of Use)

Description Benjamin Chardi 2016-07-11 07:13:17 UTC
Description of problem:

Dear friends,


We are building the DR strategy for our Satellite 6.1.9 deployment, one satellite server + 3 capules with RHEL6 and RHEL7 channels + some custom content (~ 250G on /var/lib/pulp). For the moment we have ~50 clients attached to it but in the next year we will reach more that 30K clients attached.

The problem that we are facing now (and it will be getting worst when we attach more clients) is that the recommended DR strategy for Satellite 6.1.9 (katello-backup and katello-restore) is taking more that 4 hours to complete a full backup and it requires satellite services to be stopped in order to do it.

What we need is a faster and continuos DR strategy without the need to stop satellite services. Maybe the inter satellite sync ISS feature provided on Satellite 6.2 can be used to archive it. The ideal scenario for this kind of satellite DR for us is:

* Satellite  is continuously hot-replicating content to Satellite-DR .

* Satellite-DR must be fully operational as a replica of Satellite, Satellite-DR can have some clients attached to it  and that clients must see the replicated content from Satellite. 

* In case of DR scenario, after executing some fast process on Satellite-DR the satellite services are re-established and clients can get content from Satellite-DR via Capsules. 

Version-Release number of selected component (if applicable):
Satellite 6.1.9


How reproducible:
Always when katello-backup and  katello-restore are executed

Steps to Reproduce:
1.
2.
3.

Actual results:
It takes more than 4 hours to complete katello-backup and the process need satellite to be stopped in some steps.


Expected results:
Continuous and fast katello-backup without stopping Satellite services


Additional info:

Comment 1 Christine Fouant 2017-02-03 20:05:48 UTC
Online backup has been solved by https://bugzilla.redhat.com/show_bug.cgi?id=1399244, and the faster backup will occur with https://bugzilla.redhat.com/show_bug.cgi?id=1284686

*** This bug has been marked as a duplicate of bug 1284686 ***


Note You need to log in before you can comment on or make changes to this bug.