Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354321 - [RFE] BuildOverrides cannot be automated for OSE3 installation
Summary: [RFE] BuildOverrides cannot be automated for OSE3 installation
Keywords:
Status: CLOSED DUPLICATE of bug 1320231
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jason DeTiberus
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 06:41 UTC by Alexander Koksharov
Modified: 2016-09-21 18:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-21 18:54:48 UTC


Attachments (Terms of Use)

Description Alexander Koksharov 2016-07-11 06:41:25 UTC
Description of problem:

Just like build defaults, it should be possible to configure build overrides in hosts file for ansible installation of OSE3.2.
Build defaults can be configured in hosts file according to git openshift-ansible/roles/openshift_builddefaults/tasks/main.yml, e.g. openshift_builddefaults_http_proxy can be configured. For build overrides, there is nothing.

We would like to be able to configure the following in an automated way:
kubernetesMasterConfig:
  admissionConfig:
    pluginConfig:
      BuildOverrides:
        configuration:
          apiVersion: v1
          kind: BuildOverridesConfig
          forcePull: true

As describe in https://docs.openshift.com/enterprise/3.2/install_config/build_defaults_overrides.html.


Version-Release number of selected component (if applicable):
3.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Devan Goodwin 2016-09-21 18:54:48 UTC
This should be possible with the new inventory variables which give you full control over the admission config sections for both openshift and kubernetes.

Added in https://bugzilla.redhat.com/show_bug.cgi?id=1320231 and PR https://github.com/openshift/openshift-ansible/pull/1660.

*** This bug has been marked as a duplicate of bug 1320231 ***


Note You need to log in before you can comment on or make changes to this bug.