Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354291 - Buttons are sensitive when vm is not running
Summary: Buttons are sensitive when vm is not running
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.3
Hardware: x86_64
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Grunt
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1360253
TreeView+ depends on / blocked
 
Reported: 2016-07-11 06:08 UTC by Xiaodai Wang
Modified: 2016-11-04 01:23 UTC (History)
7 users (show)

Fixed In Version: virt-viewer-2.0-11.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1360253 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:23:00 UTC


Attachments (Terms of Use)
screen shot (deleted)
2016-07-11 06:08 UTC, Xiaodai Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2229 normal SHIPPED_LIVE virt-viewer, libgovirt, spice-gtk, and usbredir bug fix and enhancement update 2016-11-03 13:26:58 UTC

Description Xiaodai Wang 2016-07-11 06:08:16 UTC
Description of problem:
A white line displays in the submenu position of "View->Displays"

Version-Release number of selected component (if applicable):
virt-viewer-2.0-10.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a shutdown guest.
2. Run virt-viewer to open the shutdown guest.
$ virt-viewer -c qemu:///system vm1 
3. Click "View->Display".

Actual results:
A white line displays in the submenu position of "View->Displays".

Expected results:
Displays menu item should not be sensitive when no displays are connected.

Additional info:
Please see attachment for the screenshot.

Comment 1 Xiaodai Wang 2016-07-11 06:08:55 UTC
Created attachment 1178248 [details]
screen shot

Comment 3 Pavel Grunt 2016-07-11 17:01:32 UTC
(In reply to xiaodwan from comment #0)
> 
> Expected results:
> Displays menu item should not be sensitive when no displays are connected.
> 
Also zoom and items in the fullscreen toolbar are sensitive when a vm is not running.

All fixed upstream by:
2b7d8717f9417511f9e12947d76e518149248d09
82d6280e5c60b70c69dbeb055af55acd51fe61c5

Comment 4 Pavel Grunt 2016-07-12 08:46:22 UTC
Sensitivity/visibility of the usb button is solved by:
529980e8d3fd7d5c042ad071b63a3fbd75ef456c

Comment 9 Xiaodai Wang 2016-07-26 02:33:44 UTC
I verified it with virt-viewer-2.0-11.el7.x86_64.

Steps:
1. Prepare a shutdown guest.
2. Run virt-viewer to open the shutdown guest.
$ virt-viewer -c qemu:///system vm1 
3. Click "View->Display", Check the "Zoom" and "Displays" item.
4. Click "View->Fullscreen" to make virt-viewer in fullscreen mode, then check the usb icon button in the toolbar.

Results:
After step3, The "Zoom" and "Displays" item are insensitive.
After step4, The usb icon is insensitive.

So move the bug from ON_QA to VERIFIED.

Comment 11 errata-xmlrpc 2016-11-04 01:23:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html


Note You need to log in before you can comment on or make changes to this bug.