Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354283 - virt-viewer will core dump when close the console window by selecting View->Displays->Display 1
Summary: virt-viewer will core dump when close the console window by selecting View->D...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Fabiano Fidêncio
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1294938
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 05:50 UTC by Marcel Kolaja
Modified: 2016-08-02 18:24 UTC (History)
13 users (show)

Fixed In Version: virt-viewer-2.0-6.el7_2.2
Doc Type: Bug Fix
Doc Text:
Prior to this update, closing a virt-viewer console by using the checkbox in the View -> Displays menu in some cases caused virt-viewer to terminate unexpectedly. This update fixes the underlying code, and thus prevents the described problem from occurring.
Clone Of: 1294938
Environment:
Last Closed: 2016-08-02 18:24:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1536 normal SHIPPED_LIVE virt-viewer and libgovirt bug fix and enhancement update 2016-08-02 22:19:56 UTC

Description Marcel Kolaja 2016-07-11 05:50:17 UTC
This bug has been copied from bug #1294938 and has been proposed
to be backported to 7.2 z-stream (EUS).

Comment 4 Xiaodai Wang 2016-07-12 08:59:10 UTC
I can reproduce it with virt-viewer-2.0-6.el7_2.1.x86_64 and a vnc guest.

and then verified this bug with virt-viewer-2.0-6.el7_2.2.x86_64, and virt-viewer does not crashed any more.

So move this bug from ON_QA to VERIFIED.

Comment 6 errata-xmlrpc 2016-08-02 18:24:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1536.html


Note You need to log in before you can comment on or make changes to this bug.