Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354271 - event-test.py coredump when pool-refresh
Summary: event-test.py coredump when pool-refresh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt-python
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 05:31 UTC by Han Han
Modified: 2016-11-04 00:13 UTC (History)
7 users (show)

Fixed In Version: libvirt-python-2.0.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 00:13:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
gdb backtrace info (deleted)
2016-07-11 05:31 UTC, Han Han
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2186 normal SHIPPED_LIVE libvirt-python bug fix and enhancement update 2016-11-03 13:18:26 UTC

Description Han Han 2016-07-11 05:31:35 UTC
Created attachment 1178232 [details]
gdb backtrace info

Description of problem:
As subject

Version-Release number of selected component (if applicable):
libvirt-python-2.0.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Execute event-test.py:
# python `locate event-test.py`
Using uri:qemu:///system

2. In another terminal, do pool-refresh:
# virsh pool-refresh default
Pool default refreshed

Then we can find python coredump in the former terminal
Using uri:qemu:///system
Fatal Python error: GC object already tracked

Actual results:
As step2

Expected results:
No Fatal Python error

Additional info:
libvirt-python-1.3.5-1.el7 not reproduced. So it's a regression

Comment 3 Pavel Hrdina 2016-07-25 08:25:26 UTC
Upstream commit:

commit a3a4425338017ecefd31b969f62a1b5803f92a5c
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Sat Jul 23 18:20:44 2016 +0200

    Fix crash in storage pool refresh callback

Comment 6 lcheng 2016-08-02 03:26:14 UTC
Verified on libvirt-python-2.0.0-2.el7.x86_64. 


1. In one terminal.
[root@localhost ~]# python `locate event-test.py`
Using uri:qemu:///system

2. In another terminal.
[root@localhost ~]# virsh pool-refresh default
Pool default refreshed

3. In the first terminal, the output as follows:
Using uri:qemu:///system
myStoragePoolEventRefreshCallback: Storage pool default


No fatal python error. Move this bug to VERIFIED.

Comment 8 errata-xmlrpc 2016-11-04 00:13:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2186.html


Note You need to log in before you can comment on or make changes to this bug.