Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354219 - Primary screen power-down causes high CPU usage and lag on secondary monitor
Summary: Primary screen power-down causes high CPU usage and lag on secondary monitor
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-10 22:24 UTC by K
Modified: 2016-11-07 23:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 23:48:14 UTC


Attachments (Terms of Use)
perf report mentioned in bug description (deleted)
2016-07-10 22:24 UTC, K
no flags Details

Description K 2016-07-10 22:24:19 UTC
Created attachment 1178182 [details]
perf report mentioned in bug description

Description of problem:
Powering down the internal screen on my Toshiba L55D-C5269 laptop (AMD A10-8700P APU, no discreet graphics) causes high CPU usage, and, when working on an external display (with the interal powered down) causes significant lag updating that display.  In addition, the internal screen "blinks" multiple brightnesses of black or near black, cycling every 800ms or so.


Version-Release number of selected component (if applicable):
4.7.0-0.rc6.git2.2.fc25.x86_64

This is the only rawhide package in my system. All other are .fc24 packages. (I'm using this to solve a problem I had with rtl8723be wifi until .fc24 release of kernel-4.7.*, but I digress.)

How reproducible:
Every time.


Steps to Reproduce:
1. Power down internal screen either through the display settings, or by locking computer, or by letting computer power it down via automated power-saving settings.
2. Wait a bit (sometimes 10-15 seconds).
3. Blick, blink, blink, lag, lag, lag, cpu fan spin, spin, spin.

Actual results:
See above.

Expected results:
None of the above.

Additional info:
Although I am reporting this against the rawhide kernel, this has been an issue since I bought the laptop (Fedora 22-ish?).

I am attaching a perf report, which shows the calls in kworker.

I would also be happy to perform additional tests, given sufficient guidance.

-K

Comment 1 K 2016-11-07 23:48:14 UTC
This problem was fixed prior to or with the following updates:

fedora version: Fedora 25 Beta
kernel: 4.8.6-300.fc25.x86_64
mesa: 12.0.3-3.fc25.x86_64


Note You need to log in before you can comment on or make changes to this bug.