Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354205 - rpc: set struct saved_frame's member rsp
Summary: rpc: set struct saved_frame's member rsp
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zhou Zhengping
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-10 18:45 UTC by Zhou Zhengping
Modified: 2018-08-29 03:35 UTC (History)
2 users (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:35:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Zhou Zhengping 2016-07-10 18:45:13 UTC
Description of problem:
    In rpc layer, we will notify RPC_TRANSPORT_MAP_XID_REQUEST event to rpc_clnt layer for getting original rpc_req when we get a reply. The info->rsp will be copyed from saved_frame.rsp in function rpc_clnt_fill_request_info.
    But the struct saved_frame's member rsp hasn't ever been set in submitting procedure which will cause request_info->rsp.payload_count==0 in function __socket_read_reply, and then it will get a new rsp_iobuf for current vectored reply, the rsp_iobuf has been set in function client3_3_readv actually.
    We don't need to get iobuf twice in one readv operation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2016-07-10 19:00:40 UTC
REVIEW: http://review.gluster.org/14883 (rpc: set struct saved_frame's member rsp) posted (#1) for review on master by Zhou Zhengping (johnzzpcrystal@gmail.com)

Comment 2 Amar Tumballi 2018-08-29 03:35:17 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.