Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354199 - Failed to install ovirt-hosted-engine-setup (due to deps issue with packages from optional)
Summary: Failed to install ovirt-hosted-engine-setup (due to deps issue with packages ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.0.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.0.1
: 4.0.1
Assignee: Eyal Edri
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1335426 1349532 1352160
TreeView+ depends on / blocked
 
Reported: 2016-07-10 15:22 UTC by Nikolai Sednev
Modified: 2017-05-11 09:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:12:34 UTC
oVirt Team: Integration


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC

Comment 4 Nikolai Sednev 2016-07-14 12:49:28 UTC
Reproduced on clean host:
--> Processing Dependency: otopi >= 1.5.1 for package: ovirt-hosted-engine-setup-2.0.1-1.el7ev.noarch
---> Package sqlite.i686 0:3.7.17-8.el7 will be installed
--> Finished Dependency Resolution
Error: Package: glusterfs-cli-3.7.1-16.el7.x86_64 (rhel-72-optional)
           Requires: glusterfs-libs = 3.7.1-16.el7
           Available: glusterfs-libs-3.7.1-16.el7.x86_64 (rhel-7.2)
               glusterfs-libs = 3.7.1-16.el7
           Installing: glusterfs-libs-3.7.9-10.el7.x86_64 (latest_rhel_z_stream)
               glusterfs-libs = 3.7.9-10.el7
Error: Package: ovirt-hosted-engine-setup-2.0.1-1.el7ev.noarch (rhev-4.0.1-2)
           Requires: otopi >= 1.5.1
           Available: otopi-1.5.0-3.el7ev.noarch (rhev-4.0.1-2)
               otopi = 1.5.0-3.el7ev
Error: Package: libvirt-lock-sanlock-1.2.17-13.el7_2.5.x86_64 (rhev-4.0.1-2)
           Requires: libvirt.so.0(LIBVIRT_PRIVATE_1.2.17)(64bit)
           Available: libvirt-client-1.2.17-13.el7.x86_64 (rhel-7.2)
               libvirt.so.0(LIBVIRT_PRIVATE_1.2.17)(64bit)
           Available: libvirt-client-1.2.17-13.el7_2.5.x86_64 (rhev-4.0.1-2)
               libvirt.so.0(LIBVIRT_PRIVATE_1.2.17)(64bit)
           Available: libvirt-client-2.0.0-2.el7.i686 (latest_rhel_z_stream)
               Not found
Error: Package: ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch (rhev-4.0.1-2)
           Requires: otopi >= 1.5.1
           Installing: otopi-1.5.0-3.el7ev.noarch (rhev-4.0.1-2)
               otopi = 1.5.0-3.el7ev
Error: Package: ovirt-hosted-engine-setup-2.0.1-1.el7ev.noarch (rhev-4.0.1-2)
           Requires: otopi >= 1.5.1
           Installing: otopi-1.5.0-3.el7ev.noarch (rhev-4.0.1-2)
               otopi = 1.5.0-3.el7ev
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Linux version 3.10.0-327.el7.x86_64 (mockbuild@x86-034.build.eng.bos.redhat.com) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Thu Oct 29 17:29:29 EDT 2015
Linux 3.10.0-327.el7.x86_64 #1 SMP Thu Oct 29 17:29:29 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)

Comment 7 Nikolai Sednev 2016-07-17 10:17:25 UTC
Still being reproduced on these components:
rhev-release-4.0.1-2-001.noarch
Linux version 3.10.0-327.30.1.el7.x86_64 (mockbuild@x86-039.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Wed Jul 13 22:09:46 EDT 2016
Linux 3.10.0-327.30.1.el7.x86_64 #1 SMP Wed Jul 13 22:09:46 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)


yum clean all && yum install screen -y && screen yum update -y && yum install -y ovirt-hosted-engine-setup && yum install -y rhevm-appliance.noarch && systemctl stop NetworkManager && chkconfig NetworkManager off && systemctl is-enabled NetworkManager && systemctl status NetworkManager

---> Package sqlite.i686 0:3.7.17-8.el7 will be installed
--> Finished Dependency Resolution
Error: Package: glusterfs-cli-3.7.1-16.el7.x86_64 (rhel-72-optional)
           Requires: glusterfs-libs = 3.7.1-16.el7
           Available: glusterfs-libs-3.7.1-16.el7.x86_64 (rhel-7.2)
               glusterfs-libs = 3.7.1-16.el7
           Installing: glusterfs-libs-3.7.9-10.el7.x86_64 (latest_rhel_z_stream)
               glusterfs-libs = 3.7.9-10.el7
Error: Package: glusterfs-cli-3.7.1-16.el7.x86_64 (rhev-4.0.1-2)
           Requires: glusterfs-libs = 3.7.1-16.el7
           Available: glusterfs-libs-3.7.1-16.el7.x86_64 (rhel-7.2)
               glusterfs-libs = 3.7.1-16.el7
           Installing: glusterfs-libs-3.7.9-10.el7.x86_64 (latest_rhel_z_stream)
               glusterfs-libs = 3.7.9-10.el7
Error: Package: libvirt-lock-sanlock-1.2.17-13.el7_2.5.x86_64 (rhev-4.0.1-2)
           Requires: libvirt.so.0(LIBVIRT_PRIVATE_1.2.17)(64bit)
           Available: libvirt-client-1.2.17-13.el7.x86_64 (rhel-7.2)
               libvirt.so.0(LIBVIRT_PRIVATE_1.2.17)(64bit)
           Available: libvirt-client-1.2.17-13.el7_2.5.x86_64 (rhev-4.0.1-2)
               libvirt.so.0(LIBVIRT_PRIVATE_1.2.17)(64bit)
           Available: libvirt-client-2.0.0-2.el7.i686 (latest_rhel_z_stream)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 8 Yaniv Kaul 2016-07-17 12:24:06 UTC
1. Are you still subscribed to optional? (rhel-72-optional above seems to suggest so)?
2. What is rhev-4.0.1-2? seems to be providing a bit too much.
3. Where did you get libvirt-client-2.0.0-2.el7.i686 (latest_rhel_z_stream) ? Is this 7.3???
4. Any idea why sqlite.i686 is being installed?

Can you list the channels and repos you are subscribed to? It looks a bit messy.

Comment 12 Nikolai Sednev 2016-07-19 14:10:55 UTC
Now it's working fine on:
rhev-release-4.0.1-2-001.noarch
sanlock-3.2.4-2.el7_2.x86_64
ovirt-imageio-daemon-0.3.0-0.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
vdsm-4.18.6-1.el7ev.x86_64
libvirt-client-1.2.17-13.el7_2.5.x86_64
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
ovirt-host-deploy-1.5.1-1.el7ev.noarch
ovirt-hosted-engine-ha-2.0.1-1.el7ev.noarch
ovirt-hosted-engine-setup-2.0.1-1.el7ev.noarch
ovirt-setup-lib-1.0.2-1.el7ev.noarch
ovirt-engine-sdk-python-3.6.7.0-1.el7ev.noarch
qemu-kvm-rhev-2.3.0-31.el7_2.18.x86_64
mom-0.5.5-1.el7ev.noarch
ovirt-imageio-common-0.3.0-0.el7ev.noarch
Linux version 3.10.0-327.30.1.el7.x86_64 (mockbuild@x86-039.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Wed Jul 13 22:09:46 EDT 2016
Linux 3.10.0-327.30.1.el7.x86_64 #1 SMP Wed Jul 13 22:09:46 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.2 (Maipo)

Comment 14 errata-xmlrpc 2016-08-23 21:12:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.