Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354194 - g++ v 6.1.1.3 do not handle include directives correctly (seen with Qt library v5.7.0)
Summary: g++ v 6.1.1.3 do not handle include directives correctly (seen with Qt librar...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-10 14:22 UTC by jan vestby
Modified: 2016-07-10 17:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-10 17:02:13 UTC


Attachments (Terms of Use)

Description jan vestby 2016-07-10 14:22:46 UTC
Description of problem: c++ compiler v6.1.1.3 mishandles include directives like #include <QWidget> (header include files with no .h at the end)


Version-Release number of selected component (if applicable):
seen only in version 6.1.1.3 on a fresh Fedora 24 install

How reproducible:
Always

Steps to Reproduce:
1. Compile a c++ source file with this type of include directive
2. 
3.

Actual results:
Compilation fails as the included file is not found

Expected results:
Compilation succeeds with the included header file

Additional info:

Comment 1 Jakub Jelinek 2016-07-10 14:28:40 UTC
Why do you think it is a g++ bug?
Does the QWidget file exist somewhere in the header file search path?
If there is just QWidget.h and not QWidget, then you should be including QWidget.h, not QWidget.

Comment 2 jan vestby 2016-07-10 16:37:17 UTC
My apologies.
I thought it was compiler bug because that was the only new thing. The real problem was a glitch in my qmake script for the build. For Qt version 5.6 I had to change the version tests, and now in Qt 5.7 I had to change back. The QWidget file exists, but with the failed version tests it was not in the include-file search path anymore. I have just verified my builds are working again.

Regards Jan Vestby


Note You need to log in before you can comment on or make changes to this bug.