Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354188 - Openshift provider port field default value ignored (cannot validate token, port value empty when provider is added)
Summary: Openshift provider port field default value ignored (cannot validate token, p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: GA
: 5.5.5
Assignee: Ari Zellner
QA Contact: Tony
URL:
Whiteboard: container
: 1355825 (view as bug list)
Depends On:
Blocks: 1355824 1355825
TreeView+ depends on / blocked
 
Reported: 2016-07-10 12:59 UTC by Tony
Modified: 2016-10-13 07:45 UTC (History)
11 users (show)

Fixed In Version: 5.5.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1355824 1355825 (view as bug list)
Environment:
CFME 5.5.5.0 Openshift 3.2
Last Closed: 2016-07-26 15:36:24 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
CFME production log (deleted)
2016-07-10 12:59 UTC, Tony
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Description Tony 2016-07-10 12:59:53 UTC
Created attachment 1178072 [details]
CFME production log

Description of problem:


Build 5.5.5.0



Steps to Reproduce:

1.Log in to appliance

2.Go to new containers provider

3.Fill in the required fields 

4.After filling in the token field, click Validate




Actual results:

Code 503 Service Unavailable


Expected results:

Token validated successfully


Additional info:

Comment 4 Federico Simoncelli 2016-07-12 12:21:12 UTC
Tony the evm log is missing. As usual that's the most interesting log to look at, can you attach that as well? Thanks.

Additionally Ari will assist you for debugging this on your env.

Comment 5 Ari Zellner 2016-07-12 13:21:20 UTC
Theres a workaround for this bug:

1. Add the provider without validating
2. goto to the provider summary page
3. Select 'Configuration' -> 'Edit this containers provider'
4. Add the correct port and click on 'validate'
5. Click on save

Comment 6 Dafna Ron 2016-07-12 13:41:50 UTC
Great! Thanks Ari. 
Tony, please try the workaround.

Comment 7 Dafna Ron 2016-07-12 13:49:45 UTC
removing blocked cases

Comment 8 Tony 2016-07-12 13:55:48 UTC
The workaround is functional and can be implemented for CFME 5.5.5.0

Comment 12 Chris Pelland 2016-07-12 15:59:51 UTC
*** Bug 1355825 has been marked as a duplicate of this bug. ***

Comment 14 Tony 2016-07-14 09:28:30 UTC
Verified in 5.5.5.2

Comment 16 errata-xmlrpc 2016-07-26 15:36:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.