Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354176 - [RFE] virt-v2v: Implement virt-v2v error messages in webadmin audit log.
Summary: [RFE] virt-v2v: Implement virt-v2v error messages in webadmin audit log.
Keywords:
Status: CLOSED DUPLICATE of bug 1350465
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-10 10:37 UTC by Nisim Simsolo
Modified: 2016-07-11 06:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-11 06:45:50 UTC
oVirt Team: Virt
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Nisim Simsolo 2016-07-10 10:37:20 UTC
Description of problem:
Currently, when import VM failed, a basic log appears in events tab (Failed to import Vm VM1 to Data Center DC1, Cluster Cluster1). 
virt-v2v error logs are very detailed and useful. It would be great to have them implemented in audit log. 

For example:
Import Windows VM with Hibernation enabled failed with the next webadmin audit log:
"Failed to import Vm win10_fast_restart to Data Center DC1, Cluster Intel1"

Observing vdsm.log for virt-v2v errors:
"virt-v2v: error: unable to mount the disk image for writing. This has 
probably happened because Windows Hibernation or Fast Restart is being used 
in this guest. You have to disable this (in the guest) in order to use 
virt-v2v."

In such case, the admin will get the correct failure message so he won't have to dig in order to find out what is the issue.

Comment 1 Michal Skrivanek 2016-07-11 06:45:50 UTC
we already work on v2v logging in bug 1350465
We're likely won't be able to display anything useful in audit log though. Well, maybe the last error.

*** This bug has been marked as a duplicate of bug 1350465 ***


Note You need to log in before you can comment on or make changes to this bug.