Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354140 - Ovirt 4.0 GUI - selection bar+text is hard to read
Summary: Ovirt 4.0 GUI - selection bar+text is hard to read
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Greg Sheremeta
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On: ovirt_ui_redesign
Blocks: 1459320
TreeView+ depends on / blocked
 
Reported: 2016-07-10 01:34 UTC by Subhendu Ghosh
Modified: 2017-12-22 07:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, it was sometimes difficult to read the text in selected table rows. The table styling has been updated to use PatternFly, which corrects this issue and makes the table much easier to read.
Clone Of:
Environment:
Last Closed: 2017-12-20 10:44:19 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
mgoldboi: planning_ack+
oourfali: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)
ovirt gui low contrast text (deleted)
2016-07-10 01:34 UTC, Subhendu Ghosh
no flags Details
selected row in 4.2 data grid (deleted)
2017-09-04 14:52 UTC, Pavel Novotny
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 76097 None None None 2017-06-21 14:20:17 UTC

Description Subhendu Ghosh 2016-07-10 01:34:39 UTC
Created attachment 1177964 [details]
ovirt gui low contrast text

Description of problem:

The color of the selection bar and the white text inside the selection bar makes it very difficult to read the highlighted/selected text.

Either a sharper contrrasting color fo the selection bar, or continue to keep the text in black font color would be much more readable.

Version-Release number of selected component (if applicable):

Ovirt 4.0

How reproducible:

Always

Steps to Reproduce:
1. select any row in the GUI - the light blue bar and white text are unreadable on systems with nominally high resolution (1900x1200)
2.
3.

Actual results:

hard to read text - sample attached 

Expected results:

easy to read selection line contents.

Additional info:

Comment 1 Serena 2016-07-11 19:24:27 UTC
oVirt isn't currently using PatternFly tables.  Might you be able to update the colors specified in PatternFly with your current table implementation?

Comment 3 Serena 2016-07-29 18:42:21 UTC
PatternFly color specs can be found here https://dl.dropboxusercontent.com/u/5892944/Data-Table-Spec.png

Comment 5 Oved Ourfali 2017-06-21 12:52:07 UTC
Greg, should this move to MODIFIED?

Comment 6 Pavel Novotny 2017-09-04 14:51:13 UTC
Verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos

Selected row in data grid is easy to read in 4.2 Webadmin.
Screenshot attached.

Comment 7 Pavel Novotny 2017-09-04 14:52:18 UTC
Created attachment 1321884 [details]
selected row in 4.2 data grid

Comment 8 Sandro Bonazzola 2017-12-20 10:44:19 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.