Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354124 - Garbled text occurs with xorg-x11-drv-intel-2.99.917-23.20160512.fc24.x86_64.rpm driver
Summary: Garbled text occurs with xorg-x11-drv-intel-2.99.917-23.20160512.fc24.x86_64....
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-09 19:35 UTC by Bob Schultz
Modified: 2016-08-16 15:00 UTC (History)
4 users (show)

Fixed In Version: xorg-x11-drv-intel-2.99.917-24.20160712.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-16 15:00:34 UTC


Attachments (Terms of Use)
Screenshot of garbled/corrupted text on F24 with -25 koji intel driver. (deleted)
2016-07-29 18:30 UTC, Bob Schultz
no flags Details
Additional screenshot of corrupted system file menu text. (deleted)
2016-07-29 18:33 UTC, Bob Schultz
no flags Details
Update-Intel Driver 2.99.917-22.20160119.fc24 also fails (deleted)
2016-08-01 10:25 UTC, Bob Schultz
no flags Details
Screenshot results of intel driver 2.99.917-21.20160119.fc24 failure (deleted)
2016-08-04 14:22 UTC, Bob Schultz
no flags Details

Description Bob Schultz 2016-07-09 19:35:29 UTC
Description of problem:


Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.99.917-23.20160512.fc24.x86_64.rpm

How reproducible:
Latest driver yields garbled text after 1-4 days of normal operation. Downgrade to older version xorg-x11-drv-intel-2.99.917-20.20160119.fc24.x86_64.rpm from koji appears to solve problem. Problem never occurred previously in over 4 years.

Steps to Reproduce:
1.update to latest version "23"
2.operate system for several days.
3.garbled text suddenly appears on 5742-6682 acer aspire
4.a logout/login (without reboot) temporarily clears problem, only to eventually reappear.

Actual results:


Expected results:


Additional info:
5742-6682 acer aspire laptop
VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Comment 1 Hans de Goede 2016-07-12 09:53:08 UTC
I've just build a new version of the intel driver which hopefully fixes this, can you please test:

http://koji.fedoraproject.org/koji/buildinfo?buildID=779664

Comment 2 Bob Schultz 2016-07-12 13:37:38 UTC
Ok. Just loaded new version and fresh reboot on the laptop. Will need to report back in 3-4 days as to success or fail, since prior failures occurred randomly and spontaneously after several days of normal operation. From the symptoms, it might have been a memory corruption problem.

Comment 3 Fedora Update System 2016-07-12 15:48:07 UTC
xorg-x11-drv-intel-2.99.917-24.20160712.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8aabc73dbf

Comment 4 Fedora Update System 2016-07-13 01:24:49 UTC
xorg-x11-drv-intel-2.99.917-24.20160712.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8aabc73dbf

Comment 5 Bob Schultz 2016-07-14 22:20:46 UTC
New driver xorg-x11-drv-intel-2.99.917-24.20160712.fc24 appears to have eliminated the problem, as did the older xorg-x11-drv-intel-2.99.917-20.20160119.fc24.x86_64 driver as well. No garbled text in the past 2.5 days. Thank you.

Comment 6 Bob Schultz 2016-07-23 16:54:47 UTC
Just returned from a 1 week vacation, fresh start on laptop with driver:
Installed Packages
xorg-x11-drv-intel.x86_64          2.99.917-24.20160712.fc24     @@commandline  

After 1 day of operation, garbled text (missing letters to be precise) reappeared.
Reverting back to xorg-x11-drv-intel-2.99.917-20.20160119.fc24.x86_64

Comment 7 Bob Schultz 2016-07-25 21:38:45 UTC
Decided to test version -25 from koji:
Installed Packages
xorg-x11-drv-intel.x86_64       2.99.917-25.20160712.fc25        @@commandline  
Available Packages
xorg-x11-drv-intel.i686         2.99.917-24.20160712.fc24        updates-testing

If this fails, will test versions -21 and -22 to help isolate the start of bug in version -23. Version -20 works.

Comment 8 Fedora Update System 2016-07-27 18:56:01 UTC
xorg-x11-drv-intel-2.99.917-24.20160712.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Bob Schultz 2016-07-27 19:07:26 UTC
Just a note: 2.99.917-24.20160712.fc24 had a bug per comment 6 above. Currently testing -25 from koji per comment 7. Good so far for ~2 days, but insufficient test time for definitive assessment. Will report if -25 fails, in which case will test per comment 7 to help isolate version-specific genesis of problem.

Comment 10 Bob Schultz 2016-07-29 18:30:19 UTC
Created attachment 1185645 [details]
Screenshot of garbled/corrupted text on F24 with -25 koji intel driver.

Version -25 koji driver just failed. This screenshot shows corrupted mate desktop, corrupted Thunderbird fields, yet only a corrupted window title on firefox.

Comment 11 Bob Schultz 2016-07-29 18:33:42 UTC
Created attachment 1185647 [details]
Additional screenshot of corrupted system file menu text.

Additional screenshot showing corruption of system file listing window.

Comment 12 Bob Schultz 2016-07-29 18:36:04 UTC
Proceeding per my comment 7, testing with version -22 and if it fails, next -21. As said before, driver version -20 works fine.

Comment 13 Bob Schultz 2016-08-01 10:25:26 UTC
Created attachment 1186335 [details]
Update-Intel Driver 2.99.917-22.20160119.fc24 also fails

Update--version "-22" fails. Will now test version "-21". Bug genesis now confined to either "-21" to "-22", or "-20" to "21"revision.

Installed Packages
xorg-x11-drv-intel.x86_64        2.99.917-22.20160119.fc24         @@commandline
Available Packages
xorg-x11-drv-intel.i686          2.99.917-24.20160712.fc24         updates      
xorg-x11-drv-intel.x86_64        2.99.917-24.20160712.fc24         updates      
flo@FS_Notebook ~$

Comment 14 Bob Schultz 2016-08-04 14:22:34 UTC
Created attachment 1187527 [details]
Screenshot results of intel driver 2.99.917-21.20160119.fc24 failure

"-21" driver failed today. Screenshot interesting in that only certain portions of gui display are corrupted..other sections are not, as shown.

This final test isolates genesis of bug in the "-20" to "-21" version.

flo@FS_Notebook ~$ dnf list installed xorg-x11-drv-intel
Last metadata expiration check: 1 day, 17:38:23 ago on Tue Aug  2 16:39:16 2016.
Installed Packages
xorg-x11-drv-intel.x86_64        2.99.917-21.20160119.fc24         @@commandline
flo@FS_Notebook ~$

Comment 15 Bob Schultz 2016-08-05 13:30:10 UTC
Update--now have garbled text with -20 version driver, which was previously reported as a working version. That prior observation and working theory is no longer true.

This Fedora install started as a mate-desktop rollout, F22->F23->F24 by fedup. Gnome was never installed. Decided to try following:

sudo dnf install @gnome-desktop

sudo dnf install system-switch-displaymanager system-switch-displaymanager-gnome

Booted into gnome desktop one time to permit any initializations, and then

sudo system-switch-displaymanager

chose gnome gdm to replace lightdm, as font corruption MAY have been occurring on the restore from screensaver login process.

Currently running:
Installed Packages
xorg-x11-drv-intel.x86_64           2.99.917-24.20160712.fc24           @updates

Time will tell if this solves the problem, but for now it appears that the intel driver might not be the cause.

Comment 16 Bob Schultz 2016-08-12 15:10:21 UTC
Update: Despite the actions noted in comment 15, plus a change of screensaver display AND the creation of a /etc/X11/xorg.conf.d/20-intel.conf file with the following contents

Section "Device"
Identifier  "card0"
Driver  "intel"
Option  "AccelMethod"  "uxa"
EndSection

to suppress any sna-related driver issues, corruption still occurred. It was noticed that in Firefox, even upon a fresh boot, the highlighting of a submenu item in say bookmarks caused the parent menu item to disappear. A test of firefox under gnome yielded correct operation. It was suspected that the mate theme might be the cause, so it was changed to something different. That change yielded correct firefox submenu operation, as well as no detectable font corruption for over 4 days. It appears at this point that previous Mate theme had a defect of some sort. Currently running all the latest test updates as of 8/12/16. Hopefully this action will resolve the problem for good.


Note You need to log in before you can comment on or make changes to this bug.