Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354123 - Gstreamer playback problem "intel_do_flush_locked failed: No such file or directory"
Summary: Gstreamer playback problem "intel_do_flush_locked failed: No such file or dir...
Keywords:
Status: CLOSED DUPLICATE of bug 1309446
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer1-vaapi
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Simon Farnsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-09 19:16 UTC by Iiro Laiho
Modified: 2016-07-10 18:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-10 12:47:23 UTC


Attachments (Terms of Use)

Description Iiro Laiho 2016-07-09 19:16:51 UTC
Description of problem:

I am unable to play h.264 videos with Totem, gstreamer codecs from RPMFusion or United RPMs and the integrated GPU of an Intel i3 4130T.

Version-Release number of selected component (if applicable):
gstreamer1-vaapi.x86_64 1.8.2-1.fc24


How reproducible:

First enable RPMFusion or United RPMs.

Then run:

# dnf install gstreamer{1,}-{ffmpeg,libav,plugins-{good,ugly,bad{,-free,-nonfree}}} --setopt=strict=0
# dnf install libva-intel-driver
$ totem toystory.mp4


Actual results:

On X11, Totem crashes immediately. On Wayland, audio plays for a few seconds before stopping. Black screen is shown instead of video.

Console output of Totem on X11:
DtsGetHWFeatures: Create File Failed
DtsGetHWFeatures: Create File Failed
Running DIL (3.22.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
intel_do_flush_locked failed: No such file or directory

If I remove package libva-intel-driver but keep gstreamer1-vaapi, it fails probably because there is no driver. It emits a error pop-up window that tells that it "could not initialize supporting library" The output is following:

DtsGetHWFeatures: Create File Failed
DtsGetHWFeatures: Create File Failed
Running DIL (3.22.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1


I am not fully sure if the problem is with this package, the codecs themselves or Fedora's gstreamer1-vaapi.

If I remove package gstreamer1-vaapi, the video plays, but of course without hardware acceleration.


Expected results:

The video should play correctly.


Additional info:

Test video used is here: http://www.html5videoplayer.net/videos/toystory.mp4

Bug report to United RPMs: https://github.com/UnitedRPMs/libva-intel-driver/issues/1

Bug report to RPMFusion: https://bugzilla.rpmfusion.org/show_bug.cgi?id=4113

Comment 1 Iiro Laiho 2016-07-10 12:47:23 UTC
On the United RPMs bug report (1) it became clear that it is bug with the Intel driver and not this package.

1) https://github.com/UnitedRPMs/libva-intel-driver/issues/1

Comment 2 Iiro Laiho 2016-07-10 18:14:50 UTC

*** This bug has been marked as a duplicate of bug 1309446 ***


Note You need to log in before you can comment on or make changes to this bug.