Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354099 - gnome-shell fails to draw background
Summary: gnome-shell fails to draw background
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-09 12:35 UTC by morgan read
Modified: 2016-08-04 10:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 10:41:39 UTC


Attachments (Terms of Use)
screenshot of white/ blank background (deleted)
2016-07-09 12:35 UTC, morgan read
no flags Details

Description morgan read 2016-07-09 12:35:11 UTC
Created attachment 1177865 [details]
screenshot of white/ blank background

Description of problem:
Install f24

Version-Release number of selected component (if applicable):
$ rpm -qa gnome-shell
gnome-shell-3.20.3-1.fc24.x86_64

How reproducible:
More often than not, but intermitant

Steps to Reproduce:
1. Install f24
2. Login to user account
3.

Actual results:
White background

Expected results:
Pretty background

Additional info:
See attached screenshot

Comment 1 Aivaras Laimikis 2016-07-14 19:16:28 UTC
Having same problem. Half of OS boots - background normal, other half white.

Comment 2 fab671 2016-07-15 14:27:46 UTC
Can confirm - happens also for me.

Comment 3 Didier G 2016-07-18 11:33:14 UTC
Same problem with gnome-shell-3.20.3-3.fc24.x86_64 on Asus UX305UA-FC057T with screen size 1980x1080

I have gnome-tweak-tool-3.20.1-1.fc24.noarch and "Icons on Desktop" is enable.

When I start session I get white background.

If using gnome-tweak-tool I switch "Icons on Desktop" to disable I get the default background. 

After that I can switch back "Icons on Desktop" to enable with no problem.

Comment 4 Didier G 2016-07-27 10:32:38 UTC
Did somebody have a look on this bug opened since 2016-07-09 ?

Comment 5 Didier G 2016-08-02 11:18:43 UTC
For me fixed by Nautilus 3.20.2 available in testing



What's new in Nautilus 3.20.2
July 29th, 2016

    Fix white desktop background after changing themes (Sebastien Keller)
    Improve double click detection (Johannes Oertel)
    Fix path bar menu on wayland appearing on random places (Olivier Fourdan)
    Only save zoom level if the level has changed (Mike Gorse)
    Fix date difference calculation for attributes like Modified Date (Ernestas Kulik)
    Hide floating bar on hover (Carlos Soriano)
    Fix detection of remote systems for not thumbnailing (Ernestas Kulik)
    Fix sorting on Japanese locale (Ernestas Kulik)
    Fix gnome shell search provider not being recursive (Carlos Soriano)
    Fix copy operation lags (Razvan Chitu)
    Avoid unresponsiveness when file chooser is opened (Ernestas Kulik)
    Fix renaming duplicated logic on search and recent (Ernestas Kulik)
    Fix trash handling to delete files if disk is full (Mario Sanchez Prada)


Read more: http://linux.softpedia.com/progChangelog/Nautilus-Changelog-4532.html

Comment 6 Florian Müllner 2016-08-04 10:41:39 UTC
I'll assume that all affected people have desktop icons enabled, and that the issue is therefore fixed by the nautilus update.
Please reopen if the assumption is wrong and you can reproduce the issue without desktop icons.


Note You need to log in before you can comment on or make changes to this bug.