Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354080 - Can't connect with hostname.local
Summary: Can't connect with hostname.local
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: avahi
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-09 08:46 UTC by jeremy9856
Modified: 2017-08-08 15:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 15:28:39 UTC


Attachments (Terms of Use)

Description jeremy9856 2016-07-09 08:46:37 UTC
Hello,

I have a problem with Avahi or something related on Fedora 24 because I can't connect to an other Fedora 24 PC by doing this "ssh hostname.local". It work if I do "ssh OtherPCip". I have an android phone with primitive ftpd that allow a ssh connection and I can connect to my phone with "ssh android.local".

It seem that avahi don't show the hostname.local to others computers on Fedora. I also tried to disable the firewall (without rebooting) but it's the same.

I managed to make the connection work from desktop to laptop but that only last for a few minutes. 

How can I make it work ? Is there a bug ?

Thanks !

Comment 1 Rex Dieter 2016-07-17 15:55:44 UTC
See also related,
https://github.com/lathiat/avahi/issues/52

Comment 2 Edgar Hoch 2016-07-23 22:20:48 UTC
I have tried "ssh hostname.local" between our Fedora 24 hosts and it works for me.

Relevant configuration:
- NetworkManager is running
- systemd-networkd is off
- avahi-daemon is running
- /etc/nsswitch.conf contains in line starting with "hosts:" mdns4_minimal
- /etc/resolv.conf is a symbolic link to /var/run/NetworkManager/resolv.conf

- "avahi-resolve --name hostname.local" resolves to a link-local ipv6 address
- "avahi-resolve -4 --name hostname.local" resolves to the ipv4 address of hostname
- "avahi-resolve --name hostname.our.domain" is not resolved

- I also have the error messages
    avahi-daemon[1848]: chroot.c: open() failed: No such file or directory
    avahi-daemon[1817]: Failed to open /etc/resolv.conf: Invalid argument

- According to other avahi-daemon messages it seems that
  - either NetworkManager is started after avahi-daemon,
  - or NetworkManager has started network devices after avahi-daemon was started,
  because avahi-daemon joins mDNS multicast group to the interfaces when it detects them.


To resolve the failed open of /etc/resolv.conf:
May it be a solution that avahi-daemon should retry to open /etc/resolv.conf after it has detected new network devices, because this file may have been changed after the network interface have been configured?

Comment 3 Fedora End Of Life 2017-07-25 21:41:54 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2017-08-08 15:28:39 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.