Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354072 - Problems with "mate" On the f24 workstation netinstall iso
Summary: Problems with "mate" On the f24 workstation netinstall iso
Keywords:
Status: CLOSED DUPLICATE of bug 1336879
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-09 01:59 UTC by Davide Repetto
Modified: 2016-07-11 20:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-11 12:52:59 UTC


Attachments (Terms of Use)

Description Davide Repetto 2016-07-09 01:59:35 UTC
Description of problem:
=======================
If MATE is chosen as a desktop environment while using the netinstall iso image from the Fedora24-workstation repository, strange things happen:

1) Cinnamon is installed alongside MATE and enabled by default in Lightdm

2) the glibc-langpack-xxx relative to the chosen locale is not installed and you get setlocale errors while executing commands.


Version-Release number of selected component (if applicable):
=============================================================
Fedora 24 netinstaliso aka "boot.iso" from fedora/linux/releases/24/Workstation/x86_64/os/images

How reproducible:
=================
Always.

Steps to Reproduce:
1. Select MATE as a desktop and maybe a non English locale.
2. Install
3. Create a default User and the root password 
4. Boot
5. Login

Actual results:
===============
You are logged in into Cinnamon
Localization is off

Expected results:
=================
You are logged in into mate
Proper localization

Comment 1 David Shea 2016-07-11 12:52:59 UTC
The first issue is a duplicate of bug 1336879. There is more information on exactly what is happening in bug 1346251: certain packages in comps are marked as to be conditionally installed if another package is installed, dnf does not support this attribute, and to resolve a imsettings dependency without this information dnf chooses to install cinnamon.

The second issue is a duplicate of bug 1352350.

*** This bug has been marked as a duplicate of bug 1336879 ***

Comment 2 Davide Repetto 2016-07-11 20:56:43 UTC
Thanks David!


Note You need to log in before you can comment on or make changes to this bug.