Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354065 - [ceph-installer] : Installation should fail or give warning message if node is CentOS 7.x
Summary: [ceph-installer] : Installation should fail or give warning message if node i...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3
Assignee: Gregory Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1342395 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 22:43 UTC by Rachana Patel
Modified: 2017-03-03 16:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-02 16:45:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1310214 None None None Never

Internal Links: 1310214

Description Rachana Patel 2016-07-08 22:43:11 UTC
Description of problem:
======================
Install ceph on node having OS CentOS 7.x


Actual results:
===============
API setup and setup/agent are not giving any error or warning


Expected results:
=================
In case of unsupported OS either it should error out or should proceed with warning

Version:
========
ceph-ansible-1.0.5-23.el7scon.noarch
ceph-installer-1.0.12-3.el7scon.noarch


How reproducible:

Comment 2 Ken Dreyer (Red Hat) 2017-01-05 23:14:48 UTC
We have to allow CentOS somehow since upstream's CI system runs on CentOS. (for example, see https://github.com/ceph/ceph-installer/pull/184)

Options would be to carry an eternal patch downstream, or some other method

Comment 3 Ken Dreyer (Red Hat) 2017-03-02 16:45:43 UTC
We don't want upstream and downstream to diverge here. If this is a management priority to spend more engineering time on a solution, please re-open

Comment 4 Ken Dreyer (Red Hat) 2017-03-03 16:51:35 UTC
*** Bug 1342395 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.