Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354062 - [ceph-installer API] : Installation fails on RHEL 6.6 with message ' Unable to determine a supported system'
Summary: [ceph-installer API] : Installation fails on RHEL 6.6 with message ' Unable t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-installer
Version: 2
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: 2
Assignee: Gregory Meno
QA Contact: vidushi
URL:
Whiteboard:
: 1354059 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 22:25 UTC by Rachana Patel
Modified: 2017-06-29 15:06 UTC (History)
8 users (show)

Fixed In Version: ceph-installer-1.3.0-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:15:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1496 normal SHIPPED_LIVE ceph-installer, ceph-ansible, and ceph-iscsi-ansible update 2017-06-19 17:14:02 UTC

Description Rachana Patel 2016-07-08 22:25:32 UTC
Description of problem:
=======================
Try to install ceph-installer API on RHEL 6.6 node.

Actual results:
==============
fails with below message


Unable to determine a supported system
will not proceed with installation
​​


Expected results:
=================
It is failing for unsupported OS but it should give right error message rather than saying 'unable to determine a supported system'

Version-Release number of selected component (if applicable):



How reproducible:
================
always


Version:
========
ceph-ansible-1.0.5-23.el7scon.noarch
ceph-installer-1.0.12-3.el7scon.noarch

Comment 2 Ken Dreyer (Red Hat) 2017-03-02 17:22:58 UTC
Here is the proposed change in the error message: https://github.com/ceph/ceph-installer/pull/194

Rachana does that look good to you?

Comment 7 errata-xmlrpc 2017-06-19 13:15:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1496

Comment 8 Drew Harris 2017-06-29 15:06:56 UTC
*** Bug 1354059 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.