Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354059 - [ceph-ansible] : ceph-ansible is not giving proper error message for unsupported RHEL 6.6
Summary: [ceph-ansible] : ceph-ansible is not giving proper error message for unsuppor...
Keywords:
Status: CLOSED DUPLICATE of bug 1354062
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 3.0
Assignee: Ken Dreyer (Red Hat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 21:54 UTC by Rachana Patel
Modified: 2017-06-29 15:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-29 13:47:04 UTC


Attachments (Terms of Use)

Description Rachana Patel 2016-07-08 21:54:44 UTC
Description of problem:
=======================
try to install ceph using ceph-ansible on node having RHEL 6.6 OS and gives following error

Actual results:
===============
TASK: [ceph.ceph-common | fail on unsupported distribution for red hat storage] *** 
failed: [magna057] => {"failed": true}
msg: Distribution not supported 6.6 by Red Hat Storage, only RHEL 7.1


Expected results:
=================
msg says supported only RHEL 7.1 which is wrong. 


Additional info:
================

Comment 2 Ken Dreyer (Red Hat) 2016-07-08 21:57:11 UTC
"Red Hat Storage" needs to be fixed, too.

Comment 3 Rachana Patel 2016-07-08 22:28:28 UTC
Version:
========
ceph-ansible-1.0.5-23.el7scon.noarch
ceph-installer-1.0.12-3.el7scon.noarch

Comment 4 Ken Dreyer (Red Hat) 2017-03-03 16:58:09 UTC
https://github.com/ceph/ceph-ansible/pull/1346

Comment 7 Drew Harris 2017-06-29 15:06:56 UTC

*** This bug has been marked as a duplicate of bug 1354062 ***


Note You need to log in before you can comment on or make changes to this bug.