Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354055 - pcp-pmda-ds389log requires perl-Date-Manip but doesn't have it as a dependency
Summary: pcp-pmda-ds389log requires perl-Date-Manip but doesn't have it as a dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nathan Scott
QA Contact: Miloš Prchlík
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 21:34 UTC by Viktor Ashirov
Modified: 2016-11-04 04:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:24:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2344 normal SHIPPED_LIVE pcp bug fix and enhancement update 2016-11-03 13:46:51 UTC

Description Viktor Ashirov 2016-07-08 21:34:37 UTC
Description of problem:
pcp-pmda-ds389log requires perl-Date-Manip but doesn't have it as a dependency

Version-Release number of selected component (if applicable):
pcp-pmda-ds389log-3.11.3-2.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. yum install pcp-pmda-ds389log-3.11.3-2.el7.x86_64
2. cd /var/lib/pcp/pmdas/ds389log
3. ./Install

Actual results:
[root@rhel7ds ds389log]# ./Install 
Date::Manip Perl module is not installed


Expected results:
perl-Date-Manip should be installed as a dependency for pcp-pmda-ds389log, Install script should complete sucessfully.

Additional info:
Workaround: 
# yum install perl-Date-Manip

Comment 2 Nathan Scott 2016-07-11 01:21:21 UTC
Marko has fixed this upstream via commit 7a975d2b739a.

Comment 4 Fedora Update System 2016-08-16 01:55:18 UTC
pcp-3.11.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b76275250f

Comment 5 Fedora Update System 2016-08-16 05:16:19 UTC
pcp-3.11.4-1.el5 has been pushed to the Fedora EPEL 5 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a51156083f

Comment 6 Fedora Update System 2016-08-16 05:56:32 UTC
pcp-3.11.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-415f0c78ed

Comment 7 Miloš Prchlík 2016-08-20 15:36:34 UTC
Verified for build pcp-3.11.3-3.el7.

Comment 8 Fedora Update System 2016-09-05 19:48:30 UTC
pcp-3.11.4-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-09-05 22:53:09 UTC
pcp-3.11.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-09-06 02:19:36 UTC
pcp-3.11.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 errata-xmlrpc 2016-11-04 04:24:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2344.html


Note You need to log in before you can comment on or make changes to this bug.