Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354029 - [RFE] Reporting on OpenShift Custom Labels
Summary: [RFE] Reporting on OpenShift Custom Labels
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.6.0
Hardware: All
OS: All
unspecified
high
Target Milestone: GA
: 5.7.0
Assignee: Federico Simoncelli
QA Contact: Einat Pacifici
URL:
Whiteboard: container
Depends On:
Blocks: 1373709 1373712 1373714 1373715 1373717 1373718 1374377
TreeView+ depends on / blocked
 
Reported: 2016-07-08 18:26 UTC by Mike Dahlgren
Modified: 2017-01-12 04:52 UTC (History)
9 users (show)

Fixed In Version: 5.7.0.1
Doc Type: If docs needed, set a value
Doc Text:
This release resolves an issue with the ability of CloudForms to generate a chargeback report using custom OpenShift tags.
Clone Of:
: 1373709 1374377 (view as bug list)
Environment:
Last Closed: 2017-01-11 20:24:12 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 Mike Dahlgren 2016-07-08 18:36:39 UTC
CloudForms needs the ability to report on custom OpenShift labels out of the box.  

For example if custom labels are setup in OpenShift to report items such as "Project", "Department", or "Location", then these should be viewable in CloudForms out of the box, and available as an option in creating reports.

Comment 3 Federico Simoncelli 2016-07-22 09:01:06 UTC
Mike this is probably a duplicate of bug 1358257. Let me know so I can probably close this. Thanks.

Comment 4 Federico Simoncelli 2016-07-22 09:05:23 UTC
(In reply to Federico Simoncelli from comment #3)
> Mike this is probably a duplicate of bug 1358257. Let me know so I can
> probably close this. Thanks.

Sorry, to clarify, that was actually a bug on a similar feature related to chargeback (which was already delivered in 5.6 GA).

This REF seems actually something new.

Comment 5 Mike Dahlgren 2016-07-22 09:09:25 UTC
Federico, I agree the other bug is an error being thrown from a provider if blank labels are used.  The primary use case of this bug is being able to add custom labels from OpenShift into a chargeback report.

Comment 6 Ari Zellner 2016-07-25 15:14:09 UTC
Mike, Im trying to figure out the exact intentions here:

1) Is the requirement to display tags as columns? meaning if we have a 'location=Minneapolis' custom tag then the user would be able to add 'location' as a column and each line in the report would show a different 'location' based on what the x defined in the 'location=x' tag.

2) Filter - Is there a requirement to filter by these tags? just one or many? 
meaning if 'location=Minneapolis' is set then the user could create a chargeback report in which only ContainerProjects with 'location=Minneapolis' would be considered in it.
Right now i think we support filtering by one tag only.

Comment 7 Mike Dahlgren 2016-07-26 15:25:16 UTC
1)  You are correct the expectation is you would be able to add the tags as a column.  See the example below.

2) Yes, that would be great, but just being able to get an output charge back report would be huge.  Having multiple filters is just a nice to have.  


The hope is once this is finished a customer could create a chart similar to the following.



*Charge back report for container usage for the last month*


Project Name  |  Department  |  Location  |  Number of Containers(* hrs?) | Total cost

Project X     |  Developers  |  Minneapolis  |  212  |  $350
Project Y     |  Developers  |  San Diego    |  399  |  $550
Project Z     |  Operations  |  Minneapolis  |  55   |  $80

Comment 10 Ari Zellner 2016-09-08 13:55:40 UTC
https://github.com/ManageIQ/manageiq/pull/10940

Comment 11 Einat Pacifici 2016-11-03 08:36:31 UTC
Verified. It is now possible to generate a chargeback report with model tags as columns in the report.


Note You need to log in before you can comment on or make changes to this bug.