Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354026 - Catalog Item Image upload dimensions is wrong
Summary: Catalog Item Image upload dimensions is wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: All
OS: All
medium
low
Target Milestone: GA
: 5.7.0
Assignee: Eric Winchell
QA Contact: Shveta
URL:
Whiteboard: service
Depends On:
Blocks: 1372769
TreeView+ depends on / blocked
 
Reported: 2016-07-08 18:12 UTC by Mike Dahlgren
Modified: 2017-01-04 12:57 UTC (History)
5 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1372769 (view as bug list)
Environment:
Last Closed: 2017-01-04 12:57:16 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)
Catalog Image upload (deleted)
2016-07-08 18:12 UTC, Mike Dahlgren
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0012 normal SHIPPED_LIVE CFME 5.7.0 bug fixes and enhancement update 2017-01-04 17:50:36 UTC
Red Hat Bugzilla 1351219 None None None Never

Internal Links: 1351219

Description Mike Dahlgren 2016-07-08 18:12:11 UTC
Created attachment 1177738 [details]
Catalog Image upload

Description of problem:

Catalog Item Image upload description states that upload file needs to be a PNG image of with "Dimensions of 350x70" is not correct.

Image can actually be a PNG or JPG, and does not require a size but should probably be a square.

See attached screenshot

Comment 2 Mike Dahlgren 2016-07-08 21:25:23 UTC
Pull request created:

https://github.com/ManageIQ/manageiq/pull/9699

Comment 3 Mike Dahlgren 2016-07-08 22:46:32 UTC
Updated Pull:

https://github.com/ManageIQ/manageiq/pull/9701

Comment 4 Dave Johnson 2016-07-13 21:27:17 UTC
This may or may not be a dupe of bug 1351219

Comment 5 Mike Dahlgren 2016-07-13 21:30:26 UTC
Not a duplicate of bug 1351219 as that image upload needs to be a specific size.

Comment 6 Mike Dahlgren 2016-07-13 21:31:08 UTC
The fix for this has been merged upstream.  

https://github.com/ManageIQ/manageiq/pull/9708

Comment 9 Shveta 2016-09-21 04:54:59 UTC
Message shown is " Requires image file in .png or .jpg format "
Verified in 5.7.0.0.20160906172503_12f65cb

Comment 11 errata-xmlrpc 2017-01-04 12:57:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0012.html


Note You need to log in before you can comment on or make changes to this bug.