Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354012 - `flatpak --user run [application name]` fails with "error: Unknow option --user"
Summary: `flatpak --user run [application name]` fails with "error: Unknow option --user"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: flatpak
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 17:10 UTC by Christian Stadelmann
Modified: 2018-10-08 09:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-08 08:55:36 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-07-08 17:10:41 UTC
Version-Release number of selected component (if applicable):
flatpak-0.6.7-1.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1. have an application installed as user (`flatpak --user install …`)
2. run `flatpak --user run [application name]`
3. watch output

Actual results:
running application fails with this error message:
error: Unknow option --user

Expected results:
run fine.

Comment 1 Christian Stadelmann 2017-04-23 23:59:10 UTC
Same issue with flatpak 0.9.2-2.fc26.

Comment 2 Christian Stadelmann 2018-10-06 10:36:21 UTC
Still present on Fedora 29 beta.

Comment 3 David King 2018-10-08 08:55:36 UTC
flatpak automatically chooses the applcation to run, and so --user is not valid as an option to run.

Comment 4 Christian Stadelmann 2018-10-08 09:34:36 UTC
(In reply to David King from comment #3)
> flatpak automatically chooses the applcation to run, and so --user is not
> valid as an option to run.

Hm, that's quite unintuitive.

I currently have permission problems as described in bug #1353998. As a result, any flatpak installed as root is broken. As a workaround, I want to force flatpak to only install its applications as user but never as root. Aliasing `flatpak` to `flatpak --user` does the trick for almost all flatpak commands except this one. Isn't it inconsistent to apply the `--user` option everywhere but to the `run` command? Also, it clearly is inconsistent to other modern system management tools such as `systemctl`.


Note You need to log in before you can comment on or make changes to this bug.