Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354005 - Command completion is broken
Summary: Command completion is broken
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: flatpak
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 16:53 UTC by Christian Stadelmann
Modified: 2016-08-12 17:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-12 16:26:47 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-07-08 16:53:11 UTC
Description of problem:
When pressing the tab key in bash, flatpak shows its help instead of completing the command.

Version-Release number of selected component (if applicable):
flatpak-0.6.7-1.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1. type `flatpak remo`
2. press tab key for autocompletion
3. watch output

Actual results:
bash shows flatpaks "--help" page plus this line at the end:

error: Unknown command 'complete'

Expected results:
ordinary command completion

Comment 1 David King 2016-08-10 16:17:11 UTC
This seems to work fine with 0.6.8. Can you test with that version and report whether it is fixed?

Comment 2 Christian Stadelmann 2016-08-12 09:00:21 UTC
(In reply to David King from comment #1)
> This seems to work fine with 0.6.8. Can you test with that version and
> report whether it is fixed?

No, issue is still present.

Comment 3 David King 2016-08-12 16:26:47 UTC
I am not able to reproduce, unfortunately.

Comment 4 Christian Stadelmann 2016-08-12 17:16:41 UTC
I think this is an issue with command aliasing (alias). Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.