Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353981 - Man page for freeipmi should display lower case version for command examples
Summary: Man page for freeipmi should display lower case version for command examples
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freeipmi
Version: 7.3
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: Rachel Sibley
URL:
Whiteboard:
Depends On:
Blocks: 1465906 1468984
TreeView+ depends on / blocked
 
Reported: 2016-07-08 15:19 UTC by Rachel Sibley
Modified: 2018-04-10 11:27 UTC (History)
3 users (show)

Fixed In Version: freeipmi-1.5.7-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1468984 (view as bug list)
Environment:
Last Closed: 2018-04-10 11:27:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0714 None None None 2018-04-10 11:27:56 UTC

Description Rachel Sibley 2016-07-08 15:19:20 UTC
Description of problem:
Minor nitpick, but the man page for freeipmi should display lower case version for command examples.

Version-Release number of selected component (if applicable):
~]# rpm -q freeipmi
freeipmi-1.2.9-8.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. man freeipmi
2.
3.

Actual results:
Ipmi-sensors

       A tool to read IPMI sensor readings to aid in system monitoring.

Ipmi-sel

       A tool to read and manage IPMI System Event Log (SEL) records to aid in system debugging.

Ipmipower

       A tool for remote power control.

Ipmiconsole

       A tool for Serial-over-Lan (SOL) console access.
.......

Expected results:
ipmi-sensors

       A tool to read IPMI sensor readings to aid in system monitoring.

ipmi-sel

       A tool to read and manage IPMI System Event Log (SEL) records to aid in system debugging.

ipmipower

       A tool for remote power control.

ipmiconsole

       A tool for Serial-over-Lan (SOL) console access.
.....

Additional info:
Examples are misleading:

~]# Ipmi-sensors
-bash: Ipmi-sensors: command not found

Comment 2 Josef Ridky 2017-08-29 08:41:42 UTC
Set for RHEL-7.5, due it is EasyFix and this issue could be solved with freeipmi rebase for RHEL-7.5.

Comment 7 Rachel Sibley 2017-11-17 17:23:46 UTC
Josef may I ask that you also update Rmcpping to rmcpping ? Otherwise, the remaining commands are now lower case. Thanks!

# man freeipmi
<snip>
       bmc-device

       A tool to perform advanced BMC commands, such as resetting the BMC, configuring ACPI, configuring SDR/SEL time, manually gen‐
       erating events, re-arming sensors, and configuring manufacturer settings.

       ipmiping

       An IPMI ping tool for debugging.

       Rmcpping

       A RMCP ping tool for debugging.

       ipmi-oem

       An IPMI tool for OEM specific commands.

       ipmidetect/ipmidetectd

       A tool and daemon for IPMI node detection.

       ipmiseld

       A daemon that regularly polls the SEL and stores the events to the local syslog.

       Additional information, examples, and general trouble-shooting can be found in each of the tool manpages.

Comment 9 Rachel Sibley 2017-11-27 20:53:19 UTC
Looks good, thanks !

~]# rpm -q freeipmi
freeipmi-1.5.7-2.el7.x86_64

~]# man freeipmi
<snip>
       ipmi-pet

       A tool to parse and interpret Platform Event Traps (PET).

       ipmi-dcmi

       A tool to perform Data Center Manageability Interface (DCMI) IPMI extension commands. Supports extensions for  asset  manage‐
       ment and power usage management.

       bmc-device

       A tool to perform advanced BMC commands, such as resetting the BMC, configuring ACPI, configuring SDR/SEL time, manually gen‐
       erating events, re-arming sensors, and configuring manufacturer settings.

       ipmiping

       An IPMI ping tool for debugging.

       rmcpping

       A RMCP ping tool for debugging.

       ipmi-oem

       An IPMI tool for OEM specific commands.

       ipmidetect/ipmidetectd

       A tool and daemon for IPMI node detection.

Comment 12 errata-xmlrpc 2018-04-10 11:27:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0714


Note You need to log in before you can comment on or make changes to this bug.