Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1353965 - netCDF4 import fails in python2
Summary: netCDF4 import fails in python2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: netcdf4-python
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-08 14:34 UTC by Jos de Kloe
Modified: 2016-07-09 20:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-09 20:39:20 UTC


Attachments (Terms of Use)

Description Jos de Kloe 2016-07-08 14:34:33 UTC
Description of problem:

On my machine, I currently see this error when I try to import the netCDF4 module:

>>> import netCDF4
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/netCDF4/__init__.py", line 3, in <module>
    from ._netCDF4 import *
  File "netCDF4/_netCDF4.pyx", line 4906, in init netCDF4._netCDF4 (netCDF4/_netCDF4.c:78258)
ImportError: cannot import name microsec_units
>>> 

Version-Release number of selected component (if applicable):

netcdf4-python-1.2.2-1.fc24.x86_64

How reproducible:

always

Steps to Reproduce:
1. install netcdf4-python on Fedora24 (64 bit)
2. start python2
3. import the module as stated above

Actual results:

import fails as detailed above

Expected results:

module should load without error

Additional info:

the python3 version seems to load without problems.

Comment 1 Orion Poplawski 2016-07-09 19:49:36 UTC
I can't reproduce.  What does:

rpm -V netcdf4-python

report?  Any chance you've installed system python modules with pip?

Comment 2 Jos de Kloe 2016-07-09 20:39:20 UTC
a, you cought me redhanded.
Well, almost.
Yes, I have had a locally installed NetCDF4 in my user account, and thought I had deleted it again, but it seems I forgot to delete the netcdftime.py module which also comes with the NetCDF4 package.
If I remove that one, then the Fedora 24 rpm runs without problems.


Note You need to log in before you can comment on or make changes to this bug.